Enable ipv6 for TV profile
[platform/upstream/curl.git] / packaging / curl.spec
index 1230c20..645939e 100644 (file)
@@ -9,11 +9,11 @@ URL:        http://curl.haxx.se/
 Source0:    %{name}-%{version}.tar.gz
 Source1001:     %{name}.manifest
 
+BuildRequires:  pkgconfig(icu-uc)
 BuildRequires:  pkgconfig(openssl)
 BuildRequires:  pkgconfig(zlib)
 BuildRequires:  pkgconfig(libcares)
 BuildRequires: pkgconfig(libnghttp2)
-
 Provides:   webclient
 
 
@@ -49,6 +49,15 @@ Obsoletes:   curl-devel < %{version}-%{release}
 libcurl is the core engine of curl; this packages contains all the libs,
 headers, and manual pages to develop applications using libcurl.
 
+%package -n libcurl-extension-dlp
+Summary:       Extensions for Tizen OS
+Provides:      libcurl-extension-dlp = %{version}-%{release}
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+
+%description -n libcurl-extension-dlp
+libcurl extensions for Tinen OS.
+
 %prep
 %setup -q
 cp %{SOURCE1001} .
@@ -60,19 +69,21 @@ cp %{SOURCE1001} .
 
 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
 CFLAGS+=" -fstack-protector-strong -Wl,-z,relro -D_FORTIFY_SOURCE=2 -fPIE -pie"
-%if "%{TIZEN_PROFILE_TV}" == "1"
+%if "%{tizen_profile_name}" == "tv"
 CFLAGS+=" -DTIZEN_TV_EXT"
-%reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
+%reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
 %else
 %reconfigure --without-nss --without-gnutls --with-openssl --enable-ipv6 \
 %endif
 --with-ca-path==/etc/ssl/certs \
 --with-ca-bundle=/etc/ssl/ca-bundle.pem \
+--with-icu-uc \
 --with-lber-lib=lber \
 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
 --disable-static \
 --with-nghttp2 \
 --without-zsh-functions-dir \
+--enable-dlp \
 
 #--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt 
 
@@ -120,3 +131,8 @@ rm -rf ${RPM_BUILD_ROOT}/usr/share/man
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/*.pc
 %{_datadir}/aclocal/libcurl.m4
+
+%files -n libcurl-extension-dlp
+%manifest %{name}.manifest
+%{_libdir}/libcurl_extension_dlp.so.*
+%license COPYING