Use icu library for IDN feature
[platform/upstream/curl.git] / packaging / curl.spec
index 4ab8837..627c279 100644 (file)
@@ -1,6 +1,6 @@
 Name:       curl
 Summary:    A utility for getting files from remote servers (FTP, HTTP, and others)
-Version:    7.53.1
+Version:    7.59.0
 Release:    1
 Group:      Applications/Internet
 License:    MIT
@@ -9,8 +9,8 @@ URL:        http://curl.haxx.se/
 Source0:    %{name}-%{version}.tar.gz
 Source1001:     %{name}.manifest
 
+BuildRequires:  pkgconfig(icu-uc)
 BuildRequires:  pkgconfig(openssl)
-BuildRequires:  pkgconfig(libidn)
 BuildRequires:  pkgconfig(zlib)
 BuildRequires:  pkgconfig(libcares)
 BuildRequires: pkgconfig(libnghttp2)
@@ -43,8 +43,6 @@ Summary:    Files needed for building applications with libcurl
 Group:      Development/Libraries
 License:    MIT
 Requires:   libcurl = %{version}-%{release}
-Requires:   libidn-devel
-Requires:      nghttp2-devel
 Provides:   curl-devel = %{version}-%{release}
 Obsoletes:   curl-devel < %{version}-%{release}
 
@@ -62,7 +60,7 @@ cp %{SOURCE1001} .
 %build
 
 export CPPFLAGS="-DHAVE_PK11_CREATEGENERICOBJECT"
-
+CFLAGS+=" -fstack-protector-strong -Wl,-z,relro -D_FORTIFY_SOURCE=2 -fPIE -pie"
 %if "%{TIZEN_PROFILE_TV}" == "1"
 CFLAGS+=" -DTIZEN_TV_EXT"
 %reconfigure --without-nss --without-gnutls --with-openssl --disable-ipv6 \
@@ -71,7 +69,7 @@ CFLAGS+=" -DTIZEN_TV_EXT"
 %endif
 --with-ca-path==/etc/ssl/certs \
 --with-ca-bundle=/etc/ssl/ca-bundle.pem \
---with-libidn \
+--with-icu-uc \
 --with-lber-lib=lber \
 --enable-manual --enable-versioned-symbols --enable-ares --enable-debug --enable-curldebug \
 --disable-static \
@@ -96,7 +94,7 @@ rm -rf $RPM_BUILD_ROOT
 
 make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
 
-rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
+rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl{,_extension_dlp}.la
 install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
 install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
 
@@ -124,4 +122,3 @@ rm -rf ${RPM_BUILD_ROOT}/usr/share/man
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/*.pc
 %{_datadir}/aclocal/libcurl.m4
-