Release 4.0.1.47
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizenfx.spec
index c16a738..d5ad76a 100644 (file)
@@ -1,17 +1,20 @@
+# Auto-generated from csapi-tizenfx.spec.in by makespec.sh
+
+%define TIZEN_NET_API_VERSION 4
+%define TIZEN_NET_RPM_VERSION 4.0.1.47+nui75
+%define TIZEN_NET_NUGET_VERSION 4.0.1-preview1-00047
+%define TIZEN_NET_INTERNAL_NUGET_VERSION 4.0.1.47
+%define NATIVE_DALI_VERSION 1.2.75
+%define CHECK_NATIVE_DEPS 1
+
 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
 %define DOTNET_NUGET_SOURCE /nuget
 
-%define _tizenfx_bin_path Artifacts
-
-%define TIZEN_NET_API_VERSION 4
-%define TIZEN_NET_NUGET_VERSION 4.0.1-preview1-00020
-%define TIZEN_NET_INTERNAL_NUGET_VERSION 4.0.1.20
-
 Name:       csapi-tizenfx
 Summary:    Assemblies of Tizen .NET
-Version:    4.0.1.20+nui61.3
+Version:    %{TIZEN_NET_RPM_VERSION}
 Release:    1
 Group:      Development/Libraries
 License:    Apache-2.0
@@ -19,14 +22,16 @@ URL:        https://www.tizen.org
 Source0:    %{name}-%{version}.tar.gz
 Source1:    %{name}.manifest
 
-BuildRequires: dotnet-build-tools
-
-BuildArch: noarch
+BuildArch:   noarch
 ExcludeArch: aarch64
 AutoReqProv: no
 
-Requires(post): vconf
+BuildRequires: dotnet-build-tools
+Requires(post): /usr/bin/vconftool
 
+%if 0%{CHECK_NATIVE_DEPS}
+BuildRequires: dali = %{NATIVE_DALI_VERSION}
+%endif
 
 %description
 %{summary}
@@ -130,6 +135,8 @@ cp %{SOURCE1} .
 
 %build
 
+%define _tizenfx_bin_path Artifacts
+
 GetFileList() {
   PROFILE=$1
   cat pkg/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
@@ -175,7 +182,7 @@ install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSE
 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
 
 %post
-vconftool set -t int "db/dotnet/tizen_api_version" %{TIZEN_NET_API_VERSION} -f
+/usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
 
 
 %files