[NUI][API11] NUI version up (nui22304)
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizenfx.spec
index b5e09b7..77df74f 100644 (file)
@@ -1,18 +1,19 @@
 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
 
-%define TIZEN_NET_API_VERSION 10
-%define TIZEN_NET_RPM_VERSION 10.0.0.999+nui22118
-%define TIZEN_NET_NUGET_VERSION 10.0.0.99999
+%define TIZEN_NET_API_VERSION 11
+%define TIZEN_NET_RPM_VERSION 11.0.0.999+nui22304
+%define TIZEN_NET_NUGET_VERSION 11.0.0.99999
 
 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
 %define DOTNET_TOOLS_PATH /usr/share/dotnet.tizen/tools
 %define DOTNET_PRELOAD_PATH /usr/share/dotnet.tizen/preload
+%define DOTNET_LIBRARY_PATH /usr/share/dotnet.tizen/lib
 %define DOTNET_NUGET_SOURCE /nuget
 
-%define TIZEN_NET_RUNTIME_IDENTIFIERS 4.0.0:5.0.0:5.5.0:6.0.0:6.5.0
-%define TIZEN_NET_TARGET_FRAMEWORK_MONIKERS tizen10.0:tizen90:tizen80:tizen70:tizen60:tizen50:tizen40
+%define TIZEN_NET_RUNTIME_IDENTIFIERS 8.0.0:7.0.0:6.5.0:6.0.0:5.5.0:5.0.0:4.0.0
+%define TIZEN_NET_TARGET_FRAMEWORK_MONIKERS net6.0-tizen8.0:net6.0-tizen:net6.0:tizen10.0:tizen90:tizen80:tizen70:tizen60:tizen50:tizen40
 
 %define UPGRADE_SCRIPT_PATH /usr/share/upgrade/scripts
 
@@ -30,6 +31,7 @@ BuildArch:   noarch
 AutoReqProv: no
 
 BuildRequires: dotnet-build-tools
+BuildRequires: pkgconfig(dali2-csharp-binder)
 Requires(post): /usr/bin/vconftool
 
 # BuildRequires for StructValidator
@@ -56,6 +58,7 @@ BuildRequires: pkgconfig(capi-ui-inputmethod)
 BuildRequires: pkgconfig(stt-engine)
 BuildRequires: pkgconfig(tts-engine)
 BuildRequires: pkgconfig(chromium-efl)
+BuildRequires: pkgconfig(libsessiond)
 %if "%{profile}" == "tv"
 BuildRequires: pkgconfig(trustzone-nwd)
 %else
@@ -215,8 +218,10 @@ install -p -m 755 packaging/500.tizenfx_upgrade.sh %{buildroot}%{UPGRADE_SCRIPT_
 %post
 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
 /usr/bin/vconftool set -t string db/dotnet/tizen_api_path %{DOTNET_ASSEMBLY_PATH} -f
-/usr/bin/vconftool set -t string db/dotnet/tizen_rid_version %{TIZEN_NET_RUNTIME_IDENTIFIERS} -f
-/usr/bin/vconftool set -t string db/dotnet/tizen_tfm_support %{TIZEN_NET_TARGET_FRAMEWORK_MONIKERS} -f
+mkdir -p %{DOTNET_LIBRARY_PATH}
+touch %{DOTNET_LIBRARY_PATH}/dotnet_resolving.info
+echo "db/dotnet/tizen_rid_version %{TIZEN_NET_RUNTIME_IDENTIFIERS}" > %{DOTNET_LIBRARY_PATH}/dotnet_resolving.info
+echo "db/dotnet/tizen_tfm_support %{TIZEN_NET_TARGET_FRAMEWORK_MONIKERS}" >> %{DOTNET_LIBRARY_PATH}/dotnet_resolving.info
 
 %files
 %license LICENSE