Release 5.0.0.443
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizenfx.spec
index f6877f9..3dd2931 100644 (file)
@@ -1,17 +1,18 @@
+# Auto-generated from csapi-tizenfx.spec.in by makespec.sh
+
+%define TIZEN_NET_API_VERSION 5
+%define TIZEN_NET_RPM_VERSION 5.0.0.443+nui66
+%define TIZEN_NET_NUGET_VERSION 5.0.0-preview1-00443
+%define TIZEN_NET_INTERNAL_NUGET_VERSION 5.0.0.443
+
 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
 %define DOTNET_NUGET_SOURCE /nuget
 
-%define _tizenfx_bin_path Artifacts
-
-%define TIZEN_NET_API_VERSION 5
-%define TIZEN_NET_NUGET_VERSION 5.0.0-preview1-00363
-%define TIZEN_NET_INTERNAL_NUGET_VERSION 5.0.0.363
-
 Name:       csapi-tizenfx
 Summary:    Assemblies of Tizen .NET
-Version:    5.0.0.363+nui61.1
+Version:    %{TIZEN_NET_RPM_VERSION}
 Release:    1
 Group:      Development/Libraries
 License:    Apache-2.0
@@ -19,14 +20,12 @@ URL:        https://www.tizen.org
 Source0:    %{name}-%{version}.tar.gz
 Source1:    %{name}.manifest
 
-BuildRequires: dotnet-build-tools
-
-BuildArch: noarch
+BuildArch:   noarch
 ExcludeArch: aarch64
 AutoReqProv: no
 
-Requires(post): vconf
-
+BuildRequires: dotnet-build-tools
+Requires(post): /usr/bin/vconftool
 
 %description
 %{summary}
@@ -130,6 +129,8 @@ cp %{SOURCE1} .
 
 %build
 
+%define _tizenfx_bin_path Artifacts
+
 GetFileList() {
   PROFILE=$1
   cat pkg/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
@@ -175,7 +176,7 @@ install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSE
 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
 
 %post
-vconftool set -t int "db/dotnet/tizen_api_version" %{TIZEN_NET_API_VERSION} -f
+/usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
 
 
 %files