Release 6.0.0.14613
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizenfx.spec
index df33859..2c7fa1a 100644 (file)
@@ -1,9 +1,8 @@
 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
 
-%define TIZEN_NET_API_VERSION 5
-%define TIZEN_NET_RPM_VERSION 5.0.0.14562+nui504
-%define TIZEN_NET_NUGET_VERSION 5.0.0.14562
-%define TIZEN_NET_INTERNAL_NUGET_VERSION 5.0.0.14562
+%define TIZEN_NET_API_VERSION 6
+%define TIZEN_NET_RPM_VERSION 6.0.0.14613+nui505
+%define TIZEN_NET_NUGET_VERSION 6.0.0.14613
 
 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
@@ -103,16 +102,6 @@ AutoReqProv: no
 %description tv
 Tizen .NET assemblies for TV profile
 
-%package ivi
-Summary:   Tizen .NET assemblies for IVI profile
-Group:     Development/Libraries
-Requires:  %{name} = %{version}-%{release}
-Requires:  csapi-tizenfx-dummy = %{version}-%{release}
-AutoReqProv: no
-
-%description ivi
-Tizen .NET assemblies for IVI profile
-
 %package wearable
 Summary:   Tizen .NET assemblies for Wearable profile
 Group:     Development/Libraries
@@ -134,21 +123,22 @@ cp %{SOURCE1} .
 
 GetFileList() {
   PROFILE=$1
-  cat pkg/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
+  cat packaging/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
 }
 
 GetFileList common > common.filelist
 GetFileList mobile > mobile.filelist
 GetFileList mobile-emul > mobile-emul.filelist
 GetFileList tv > tv.filelist
-GetFileList ivi > ivi.filelist
 GetFileList wearable > wearable.filelist
 
 rm -fr %{_tizenfx_bin_path}
 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
-./build.sh --full
-./build.sh --dummy
-./build.sh --pack %{TIZEN_NET_NUGET_VERSION} %{TIZEN_NET_INTERNAL_NUGET_VERSION}
+
+%define build_cmd ./tools/scripts/retry.sh ./tools/scripts/timeout.sh -t 600 ./build.sh
+%{build_cmd} --full
+%{build_cmd} --dummy
+%{build_cmd} --pack %{TIZEN_NET_NUGET_VERSION}
 
 %install
 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
@@ -163,8 +153,6 @@ install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.dll %{buildroot}%{DOTNET_A
 # Install Debug Symbols
 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
-[ -d %{_tizenfx_bin_path}/bin/external ] \
-  && install -p -m 644 %{_tizenfx_bin_path}/bin/external/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
 
 # Install Resource files
 [ -d %{_tizenfx_bin_path}/bin/public/res ] \
@@ -177,6 +165,7 @@ install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSE
 
 # Install NuGet Packages
 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
+install -p -m 644 packaging/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
 
 %post
 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
@@ -211,8 +200,5 @@ install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE
 %files tv -f tv.filelist
 %manifest %{name}.manifest
 
-%files ivi -f ivi.filelist
-%manifest %{name}.manifest
-
 %files wearable -f wearable.filelist
 %manifest %{name}.manifest