Added TimeChanged get value API and modified exception.
[platform/core/csapi/system-settings.git] / packaging / csapi-system-settings.spec
index ecfa411..b870a4b 100644 (file)
@@ -1,16 +1,6 @@
-%{!?dotnet_assembly_path: %define dotnet_assembly_path /opt/usr/share/dotnet.tizen/framework}
-
-%if 0%{?tizen_build_devel_mode}
-%define BUILDCONF Debug
-%else
-%define BUILDCONF Release
-%endif
-
-ExcludeArch: %{ix86} aarch64
-
 Name:       csapi-system-settings
 Summary:    Tizen System Settings API for C#
-Version:    1.0.1
+Version:    1.0.4
 Release:    1
 Group:      Development/Libraries
 License:    Apache-2.0
@@ -19,59 +9,36 @@ Source0:    %{name}-%{version}.tar.gz
 Source1:    %{name}.manifest
 
 AutoReqProv: no
-
-BuildRequires: mono-compiler
-BuildRequires: mono-devel
+ExcludeArch: aarch64
 
 BuildRequires: dotnet-build-tools
 
 # C# API Requires
 BuildRequires: csapi-tizen-nuget
 
+%define Assemblies Tizen.System.SystemSettings
+
 %description
-Tizen System Settings API for C#
+%{summary}
+
+%dotnet_import_sub_packages
 
 %prep
 %setup -q
 cp %{SOURCE1} .
 
-%define Assemblies Tizen.System.SystemSettings
-
 %build
 for ASM in %{Assemblies}; do
-# NuGet Restore
-find $ASM/*.project.json -exec nuget restore {} \;
-# Build
-find $ASM/*.csproj -exec xbuild {} /p:Configuration=%{BUILDCONF} \;
-# NuGet Pack
-nuget pack $ASM/$ASM.nuspec -Version %{version} -Properties Configuration=%{BUILDCONF}
+%dotnet_build $ASM
+%dotnet_pack $ASM/$ASM.nuspec %{version}
 done
 
 %install
-# Runtime Binary
-mkdir -p %{buildroot}%{dotnet_assembly_path}
 for ASM in %{Assemblies}; do
-%if 0%{?_with_corefx}
-  install -p -m 644 $ASM/bin/%{BUILDCONF}/$ASM.dll %{buildroot}%{dotnet_assembly_path}
-%else
-  install -p -m 644 $ASM/bin/%{BUILDCONF}/Net45/$ASM.dll %{buildroot}%{dotnet_assembly_path}
-%endif
+%dotnet_install $ASM
 done
-# NuGet
-mkdir -p %{buildroot}/nuget
-install -p -m 644 *.nupkg %{buildroot}/nuget
 
 %files
 %manifest %{name}.manifest
 %license LICENSE
-%attr(644,root,root) %{dotnet_assembly_path}/*.dll
-
-%package nuget
-Summary:   NuGet package for %{name}
-Group:     Development/Libraries
-
-%description nuget
-NuGet package for %{name}
-
-%files nuget
-/nuget/*.nupkg
+%attr(644,root,root) %{dotnet_assembly_files}