Change assembly installation path
[platform/core/csapi/tizenfx.git] / packaging / csapi-location.spec
index a94a0c4..72930d6 100755 (executable)
@@ -1,8 +1,13 @@
-%define dllpath %{_libdir}/mono/tizen
-%define dllname Tizen.Location.dll
+%{!?dotnet_assembly_path: %define dotnet_assembly_path %{_datadir}/assembly}
+
+%if 0%{?tizen_build_devel_mode}
+%define BUILDCONF Debug
+%else
+%define BUILDCONF Release
+%endif
 
 Name:       csapi-location
-Summary:    Tizen Location API's for C#
+Summary:    Tizen Location API for C#
 Version:    1.0.0
 Release:    1
 Group:      Development/Libraries
@@ -10,74 +15,46 @@ License:    Apache-2.0
 URL:        https://www.tizen.org
 Source0:    %{name}-%{version}.tar.gz
 Source1:    %{name}.manifest
-Source2:    %{name}.pc.in
 
-# TODO: replace mono-compiler, mono-devel to mcs, mono-shlib-cop
+# Mono
 BuildRequires: mono-compiler
 BuildRequires: mono-devel
-# TODO: replace mono-core to gacutil.
-#       mono-core should provide the symbol 'gacutil'
-Requires(post): mono-core
-Requires(postun): mono-core
 
-# P/Invoke Dependencies
+# P/Invoke Build Requires
 BuildRequires: pkgconfig(glib-2.0)
-BuildRequires: pkgconfig(csapi-tizen)
-
-# P/Invoke Runtime Dependencies
-# TODO: It should be removed after fix tizen-rpm-config
-Requires: glib-2.0
 BuildRequires: pkgconfig(capi-location-manager)
-# DLL Dependencies
-#BuildRequires: ...
-
-%description
-Tizen API for C#
 
-%package devel
-Summary:    Development package for %{name}
-Group:      Development/Libraries
-Requires:   %{name} = %{version}-%{release}
+# C# API Requires
+BuildRequires: csapi-tizen
 
-%description devel
-Development package for %{name}
+%description
+Tizen Location API for C#
 
 %prep
 %setup -q
-
 cp %{SOURCE1} .
 
-%build
-# build dll
-mcs -target:library -out:%{dllname} -keyfile:Tizen.Location/Tizen.Location.snk -pkg:'csapi-tizen'\
-  Tizen.Location/Properties/AssemblyInfo.cs \
-  Tizen.Location/Interop/*.cs \
-  Tizen.Location/Tizen.Location/*.cs
+%define Assemblies Tizen.Location
 
-# check p/invoke
-if [ -x %{dllname} ]; then
-  RET=`mono-shlib-cop %{dllname}`; \
-  CNT=`echo $RET | grep -E "^error:" | wc -l`; \
-  if [ $CNT -gt 0 ]; then exit 1; fi
-fi
+%build
+for ASM in %{Assemblies}; do
+xbuild $ASM/$ASM.csproj \
+        /p:Configuration=%{BUILDCONF} \
+        /p:ReferencePath=%{dotnet_assembly_path}
+done
 
 %install
-# copy dll
-mkdir -p %{buildroot}%{dllpath}
-install -p -m 644 %{dllname} %{buildroot}%{dllpath}
+# Assemblies
+mkdir -p %{buildroot}%{dotnet_assembly_path}
+for ASM in %{Assemblies}; do
+install -p -m 644 $ASM/bin/%{BUILDCONF}/$ASM.dll %{buildroot}%{dotnet_assembly_path}
+done
 
-# generate pkgconfig
-mkdir -p %{buildroot}%{_libdir}/pkgconfig
-sed -e "s#@version@#%{version}#g" \
-    -e "s#@dllpath@#%{dllpath}#g" \
-    -e "s#@dllname@#%{dllname}#g" \
-    %{SOURCE2} > %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
-
-%post
-gacutil -i %{dllpath}/%{dllname}
+# License
+mkdir -p %{buildroot}%{_datadir}/license
+cp LICENSE %{buildroot}%{_datadir}/license/%{name}
 
 %files
-%{dllpath}/%{dllname}
-
-%files devel
-%{_libdir}/pkgconfig/%{name}.pc
+%manifest %{name}.manifest
+%attr(644,root,root) %{dotnet_assembly_path}/*.dll
+%attr(644,root,root) %{_datadir}/license/%{name}