change the sysroot and c++ include path to fix the bugs the application cannot find...
[platform/upstream/gcc48.git] / packaging / cross-x86_64-gcc48-icecream-backend.spec
index 0f6511c..3d2999a 100644 (file)
@@ -286,6 +286,9 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
        --disable-plugin \
        --with-bugurl="http://bugs.tizen.org/" \
        --with-pkgversion="Tizen" \
+%if !%{build_fortran}
+       --disable-libquadmath \
+%endif
 %if !%{build_libjava}
         --disable-libgcj \
 %else
@@ -308,9 +311,8 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
        --enable-linker-build-id \
 %if 0%{?gcc_target_arch:1}
 %if 0%{?gcc_icecream:1}
-       --with-build-sysroot=/ \
-       --with-sysroot=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi} \
-       --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/usr/include/c++/%{gcc_dir_version} \
+       --with-sysroot=/ \
+       --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/include/c++/%{gcc_dir_version} \
        --enable-linux-futex \
 %endif
 %if 0%{?canonical_target:1}
@@ -349,6 +351,7 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
        --with-tune=cortex-a8 \
        --with-float=softfp \
        --with-fpu=vfpv3 \
+       --with-mode=thumb \
        --disable-sjlj-exceptions \
 %endif
 %if  "%{TARGET_ARCH}" == "armv7hl"