Adding the manifest
[platform/upstream/gcc48.git] / packaging / cross-armv7hl-gcc48-icecream-backend.spec
index 433ff2b..42d9944 100644 (file)
@@ -1,5 +1,5 @@
 #
-# spec file for package gcc (Version 4.0.1)
+# spec file for package gcc (Version 4.8.2)
 #
 # Copyright (c) 2005 SUSE Linux AG, Nuernberg, Germany.
 # This file and all modifications and additions to the pristine
@@ -56,7 +56,7 @@ ExclusiveArch: ppc ppc64 %ix86 x86_64 ia64
 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
 
 URL:          http://gcc.gnu.org/
-Version: 4.8.1
+Version: 4.8.2
 Release:      1
 %define gcc_dir_version 4.8
 %define binsuffix -4.8
@@ -66,6 +66,7 @@ Source1:      change_spec
 Source3:       gcc48-rpmlintrc
 Source4:       ecj.jar
 Source6:       baselibs.conf
+Source1001: gcc.manifest
 
 
 Group:         Development/Toolchain
@@ -135,6 +136,7 @@ gcc-obj-c++.
 
 %prep
 %setup -q -n gcc-%{version}
+cp %{SOURCE1001} .
 
 
 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
@@ -286,6 +288,9 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
        --disable-plugin \
        --with-bugurl="http://bugs.tizen.org/" \
        --with-pkgversion="Tizen" \
+%if !%{build_fortran}
+       --disable-libquadmath \
+%endif
 %if !%{build_libjava}
         --disable-libgcj \
 %else
@@ -308,9 +313,8 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
        --enable-linker-build-id \
 %if 0%{?gcc_target_arch:1}
 %if 0%{?gcc_icecream:1}
-       --with-build-sysroot=/ \
-       --with-sysroot=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi} \
-       --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/usr/include/c++/%{gcc_dir_version} \
+       --with-sysroot=/ \
+       --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/include/c++/%{gcc_dir_version} \
        --enable-linux-futex \
 %endif
 %if 0%{?canonical_target:1}