[SPIN] Apply system socket - onlycap support
[platform/upstream/connman.git] / packaging / connman.spec
index ed731fe..fcad6f7 100755 (executable)
@@ -17,6 +17,7 @@ BuildRequires:  pkgconfig(libiptc)
 BuildRequires:  pkgconfig(xtables)
 BuildRequires:  pkgconfig(libsmack)
 BuildRequires:  pkgconfig(tpkp-gnutls)
+BuildRequires:  pkgconfig(libsystemd-daemon)
 %if %{with connman_openconnect}
 BuildRequires:  openconnect
 %endif
@@ -103,6 +104,16 @@ VPN_CFLAGS+=" -DTIZEN_EXT -lsmack -Werror"
 %if 0%{?sec_product_feature_telephony_disable} == 1
        CFLAGS+=" -DTIZEN_CONNMAN_NTP"
 %endif
+%if 0%{?sec_product_feature_security_fstek_enable} == 1
+        CFLAGS+=" -DTIZEN_CONNMAN_USE_BLACKLIST"
+%endif
+%if 0%{?sec_product_feature_profile_wearable}
+       CFLAGS+=" -DTIZEN_WEARABLE"
+%endif
+
+%if 0%{?sec_product_feature_wlan_always_powered}
+       CFLAGS+=" -DTIZEN_ALWAYS_POWERED"
+%endif
 %endif
 
 chmod +x bootstrap