add license
[framework/api/url-download.git] / packaging / capi-web-url-download.spec
index b1a85fd..ad50b4a 100644 (file)
@@ -1,23 +1,18 @@
-%define ENABLE_DOWNLOAD_PROVIDER 1
 
 Name:  capi-web-url-download
 Summary:       CAPI for content download with web url
-Version:       0.0.7
-Release:       2
-Group:         TO_BE_FILLED_IN
+Version:       0.0.8
+Release:       9
+Group:         Development/Libraries
 License:       TO_BE_FILLED_IN
-URL:           N/A
+URL:           Apache
 Source0:       %{name}-%{version}.tar.gz
 BuildRequires: pkgconfig(capi-base-common)
 BuildRequires: pkgconfig(bundle)
 BuildRequires: pkgconfig(dlog)
-%if %ENABLE_DOWNLOAD_PROVIDER
 BuildRequires: pkgconfig(capi-appfw-app-manager)
 BuildRequires: pkgconfig(capi-appfw-application)
 BuildRequires: pkgconfig(download-provider)
-%else
-BuildRequires: pkgconfig(libdownload-agent)
-%endif
 BuildRequires: cmake
 BuildRequires: expat-devel
 
@@ -25,9 +20,9 @@ BuildRequires: expat-devel
 CAPI for the content download
 
 %package devel
-Summary:    url download
-Group:      Development/Libraries
-Requires:   %{name} = %{version}-%{release}
+Summary:       url download
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 CAPI for content downloading with web url (developement files)
@@ -50,15 +45,59 @@ rm -rf %{buildroot}
 
 %files
 %defattr(-,root,root,-)
-/usr/lib/libcapi-web-url-download.so
+%{_libdir}/libcapi-web-url-download.so
 
 %files devel
 %defattr(-,root,root,-)
-/usr/lib/libcapi-web-url-download.so
-/usr/lib/pkgconfig/capi-web-url-download.pc
+%{_libdir}/libcapi-web-url-download.so
+%{_libdir}/pkgconfig/capi-web-url-download.pc
 /usr/include/web/url_download.h
 
 %changelog
+* Fri Sep 07 2012 Kwangmin Bang <justine.bang@samsung.com>
+- fix timeout thread can run exactly
+
+* Thu Sep 06 2012 Kwangmin Bang <justine.bang@samsung.com>
+- check the state before clear socket
+- add limitation in already completed state
+- add checking INVALID_STATE error
+
+* Tue Sep 04 2012 Jungki Kwak <jungki.kwak@samsung.com>
+- Remove unused code which is base on libdownload-agent
+- Change the name of application operation
+- Add exception handling for non requestid
+- Call clear_provider after getting the state
+- url_download_get_state return IO error
+- Resolve prevent defects
+
+* Mon Sep 03 2012 Kwangmin Bang <justine.bang@samsung.com>
+- stop the download even if no socket or callback
+- pause/resume the download even if no socket or callback
+- calling stopped callback in error case
+- request STOP for free after finished download
+
+* Thu Aug 30 2012 Kwangmin Bang <justine.bang@samsung.com>
+- maxfd should be updated before created event thread
+
+* Thu Aug 30 2012 Kwangmin Bang <justine.bang@samsung.com>
+- remove duplicated call for creating socket
+- fix the crash regarding pthread_kill
+- allow to call url_download_stop in case of PAUSED state
+
+* Mon Aug 27 2012 Kwangmin Bang <justine.bang@samsung.com>
+- one thread model for event
+- get state info from download-provider even if no connection
+- fix the bug take a long time to receive first event
+
+* Tue Aug 22 2012 Jungki Kwak <jungki.kwak@samsung.com>
+- Enhance the exception handling in event thread
+- Resolve a bug about state
+- Add to pass service handle data to download daemon
+
+* Mon Aug 17 2012 Jungki Kwak <jungki.kwak@samsung.com>
+- Resolve a bug when getting a state
+- Add error case for invalid id
+
 * Mon Aug 16 2012 Jungki Kwak <jungki.kwak@samsung.com>
 - Add new APIs for notification function
 - The TC is changed due to change of url_download_start