Update package version to 0.1.80
[platform/core/uifw/capi-ui-sticker.git] / packaging / capi-ui-sticker.spec
index 82fc3b4..e3f16ce 100644 (file)
@@ -1,6 +1,6 @@
 Name:       capi-ui-sticker
 Summary:    Sticker client library and daemon
-Version:    0.1.69
+Version:    0.1.80
 Release:    1
 Group:      Graphics & UI Framework/Input
 License:    Apache-2.0
@@ -85,7 +85,6 @@ Group:      Graphics & UI Framework/Input
 Sticker client library and daemon (gcov)
 %endif
 
-%if %{defined _ctest_enable}
 %package unittests
 Summary:    Sticker tests
 Group:      Development/Libraries
@@ -93,7 +92,6 @@ Requires:   %{name} = %{version}-%{release}
 
 %description unittests
 GTest for sticker
-%endif
 
 %prep
 %setup -q -n %{name}-%{version}
@@ -117,12 +115,7 @@ export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -fvisibility=hidden"
 %endif
          -DCMAKE_INSTALL_PREFIX=/usr -DLIBDIR=%{_libdir} -DBINDIR=%{_bindir} -DINCLUDEDIR=%{_includedir} \
          -DTZ_SYS_RO_SHARE=%TZ_SYS_RO_SHARE -DTZ_SYS_BIN=%TZ_SYS_BIN -DTZ_USER_SHARE=%TZ_USER_SHARE \
-         -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
-%if %{defined _ctest_enable}
-    -DTEST_ENABLE="%{_ctest_enable}" \
-%else
-    -DTEST_ENABLE="false" \
-%endif
+         -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
 
 make %{?jobs:-j%jobs}
 
@@ -147,8 +140,8 @@ mkdir -p %{buildroot}%{_sysconfdir}/dbus-1/system.d
 install -m 0644 %SOURCE3 %{buildroot}%{_sysconfdir}/dbus-1/system.d/capi-ui-sticker.conf
 
 %if 0%{?gcov:1}
-install -d -m 755 %{buildroot}%{_datadir}/gcov/obj
-tar xf %{name}-gcov.tar -C %{buildroot}%{_datadir}/gcov/obj
+install -d -m 755 %{buildroot}%{_datadir}/gcov/obj/%{name}
+tar xf %{name}-gcov.tar -C %{buildroot}%{_datadir}/gcov/obj/%{name}
 %endif
 
 %if 0%{?sec_product_feature_profile_wearable}
@@ -160,13 +153,12 @@ tar xf %{name}-gcov.tar -C %{buildroot}%{_datadir}/gcov/obj
 %endif
 
 %check
-%if "%{_ctest_enable}" == "true"
-ctest --output-on-failure %{?_smp_mflags}
-%endif
-
 %if 0%{?gcov:1}
-lcov -c --ignore-errors graph --no-external -q -d . -o gcov.info
-genhtml gcov.info
+ctest --output-on-failure %{?_smp_mflags}
+lcov -c --ignore-errors graph --no-external -q -d . -o capi-ui-sticker.info
+genhtml capi-ui-sticker.info -o capi-ui-sticker.out
+zip -r capi-ui-sticker.zip capi-ui-sticker.out capi-ui-sticker.info
+install -m 0644 capi-ui-sticker.zip %{buildroot}%{_datadir}/gcov
 %endif
 
 %post
@@ -214,10 +206,9 @@ chsmack -a "User::App::Shared" /opt/usr/share/sticker-data
 %{TZ_SYS_RO_APP}/%{_companion_app_name}/*
 %endif
 
-%if %{defined _ctest_enable}
 %files unittests
-%{_bindir}/*
-%endif
+%license LICENSE
+%{_bindir}/sticker_unittests
 
 %if 0%{?gcov:1}
 %files gcov