Update package version to 0.1.22
[platform/core/uifw/capi-ui-sticker.git] / packaging / capi-ui-sticker.spec
index 1efb809..d36c513 100644 (file)
@@ -1,6 +1,6 @@
 Name:       capi-ui-sticker
 Summary:    Sticker client library and daemon
-Version:    0.1.7
+Version:    0.1.22
 Release:    1
 Group:      Graphics & UI Framework/Input
 License:    Apache-2.0
@@ -23,6 +23,21 @@ BuildRequires:  pkgconfig(json-glib-1.0)
 BuildRequires:  pkgconfig(libtzplatform-config)
 BuildRequires:  pkgconfig(pkgmgr-info)
 BuildRequires:  pkgconfig(sqlite3)
+
+%if 0%{?sec_product_feature_profile_wearable}
+BuildRequires:  pkgconfig(capi-base-common)
+BuildRequires:  pkgconfig(capi-appfw-service-application)
+BuildRequires:  pkgconfig(capi-message-port)
+BuildRequires:  pkgconfig(capi-appfw-alarm)
+BuildRequires:  pkgconfig(capi-system-device)
+BuildRequires:  pkgconfig(sap-client-stub-api)
+BuildRequires:  pkgconfig(vconf)
+BuildRequires:  hash-signer
+
+Requires(post): signing-client
+Requires:       org.tizen.sticker-receiver
+%endif
+
 Requires:       security-config
 Requires(post): /sbin/ldconfig
 Requires(post): dbus
@@ -36,9 +51,24 @@ Summary:    Sticker client library and daemon (Development)
 Group:      Graphics & UI Framework/Input
 Requires:   %{name} = %{version}-%{release}
 
+%if 0%{?sec_product_feature_profile_wearable}
+%define _companion_app_name org.tizen.sticker-receiver
+
+%package -n %{_companion_app_name}
+Summary:    Sticker companion service
+Group:      Graphics & UI Framework/Input
+Requires:   %{name} = %{version}-%{release}
+%endif
+
+
 %description devel
 Sticker client library and daemon (Development)
 
+%if 0%{?sec_product_feature_profile_wearable}
+%description -n %{_companion_app_name}
+Sticker companion service
+%endif
+
 %if 0%{?gcov:1}
 %package gcov
 Summary:  Sticker client library and daemon (gcov)
@@ -63,8 +93,13 @@ export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -fvisibility=hidden -Werror"
 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -fvisibility=hidden -Werror"
 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -fvisibility=hidden"
 
-%cmake . -DCMAKE_INSTALL_PREFIX=/usr -DLIBDIR=%{_libdir} -DBINDIR=%{_bindir} -DINCLUDEDIR=%{_includedir} \
-         -DTZ_SYS_RO_SHARE=%TZ_SYS_RO_SHARE -DTZ_SYS_BIN=%TZ_SYS_BIN -DTZ_SYS_SHARE=%TZ_SYS_SHARE
+%cmake . \
+%if 0%{?sec_product_feature_profile_wearable}
+        -DCOMPANION_MODE=true \
+%endif
+         -DCMAKE_INSTALL_PREFIX=/usr -DLIBDIR=%{_libdir} -DBINDIR=%{_bindir} -DINCLUDEDIR=%{_includedir} \
+         -DTZ_SYS_RO_SHARE=%TZ_SYS_RO_SHARE -DTZ_SYS_BIN=%TZ_SYS_BIN -DTZ_SYS_SHARE=%TZ_SYS_SHARE \
+         -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
 make %{?jobs:-j%jobs}
 
 %if 0%{?gcov:1}
@@ -90,6 +125,14 @@ mkdir -p %{buildroot}%{_datadir}/gcov/obj
 install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj
 %endif
 
+%if 0%{?sec_product_feature_profile_wearable}
+%define tizen_sign 1
+%define tizen_sign_base %{TZ_SYS_RO_APP}/%{_companion_app_name}
+%define tizen_sign_level public
+%define tizen_author_sign 1
+%define tizen_dist_sign 1
+%endif
+
 %post
 /sbin/ldconfig
 
@@ -123,6 +166,17 @@ chsmack -a "System::Shared" %{TZ_SYS_SHARE}/sticker-data
 %{_includedir}/sticker_consumer.h
 %{_includedir}/sticker_provider.h
 
+%if 0%{?sec_product_feature_profile_wearable}
+%post -n %{_companion_app_name}
+/usr/bin/signing-client/hash-signer-client.sh -a -d -p platform %{TZ_SYS_RO_APP}/%{_companion_app_name}
+
+%files -n %{_companion_app_name}
+%manifest receiver/%{_companion_app_name}.manifest
+%license LICENSE
+%{TZ_SYS_RO_PACKAGES}/%{_companion_app_name}.xml
+%{TZ_SYS_RO_APP}/%{_companion_app_name}/*
+%endif
+
 %if 0%{?gcov:1}
 %files gcov
 %{_datadir}/gcov/obj/*