Add smack label (capi-system-haptic)
[platform/core/api/haptic.git] / packaging / capi-system-haptic.spec
index fe7f8ca..ec4cec8 100644 (file)
@@ -1,15 +1,20 @@
+#sbs-git:slp/api/haptic capi-system-haptic 0.1.0 0092e2c55dbf60717ae8f43aee931f2dd1c57157
 Name:       capi-system-haptic
-Summary:    A Haptic library in Tizen Native API
-Version:    0.0.1
-Release:    1
+Summary:    A Haptic library in Tizen C API
+Version:    0.1.0
+Release:    22
 Group:      TO_BE/FILLED_IN
 License:    TO BE FILLED IN
 Source0:    %{name}-%{version}.tar.gz
+Source1:       capi-system-haptic.manifest
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(devman)
 BuildRequires:  pkgconfig(devman_haptic)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(capi-base-common)
+BuildRequires:  pkgconfig(devman)
+BuildRequires:  pkgconfig(dlog)
+
 Requires(post): /sbin/ldconfig  
 Requires(postun): /sbin/ldconfig
 
@@ -17,7 +22,7 @@ Requires(postun): /sbin/ldconfig
 
 
 %package devel
-Summary:  A Haptic library in Tizen Native API (Development)
+Summary:  A Haptic library in Tizen C API (Development)
 Group:    TO_BE/FILLED_IN
 Requires: %{name} = %{version}-%{release}
 
@@ -30,7 +35,9 @@ Requires: %{name} = %{version}-%{release}
 
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=/usr
+cp %{SOURCE1} .
+MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
+cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
 
 
 make %{?jobs:-j%jobs}
@@ -45,10 +52,35 @@ rm -rf %{buildroot}
 
 
 %files
-%{_libdir}/libcapi-system-haptic.so
+%manifest capi-system-haptic.manifest
+%{_libdir}/libcapi-system-haptic.so.*
 
 %files devel
 %{_includedir}/system/*.h
 %{_libdir}/pkgconfig/*.pc
+%{_libdir}/libcapi-system-haptic.so
+
+%changelog
+* Wed Oct 17 2012 - Jiyoung Yun <jy910.yun@samsung.com>
+- fix the build break problem
+- Tag : capi-system-haptic_0.1.0-22
+
+* Thu Oct 04 2012 - Jiyoung Yun <jy910.yun@samsung.com>
+- fix the bug regarding haptic_level_auto
+- Tag : capi-system-haptic_0.1.0-21
+
+* Fri Sep 21 2012 - Jiyoung Yun <jy910.yun@samsung.com>
+- Add smack label
+- Tag : capi-system-haptic_0.1.0-20
+
+* Thu Sep 06 2012 - Jiyoung Yun <jy910.yun@samsung.com>
+- fix TC error
+- Tag : capi-system-haptic_0.1.0-19
 
+* Thu Aug 16 2012 - Jiyoung Yun <jy910.yun@samsung.com>
+- modify the function parameter to control detail feedback level
+- Tag : capi-system-haptic_0.1.0-17
 
+* Thu Aug 09 2012 - Jiyoung Yun <jy910.yun@samsung.com>
+- Revert "add level parameter to monotone vibration function."
+- Tag : capi-system-haptic_0.1.0-16