Fixed wrong parameter for checking feature
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
index c43b978..dca3201 100644 (file)
@@ -1,19 +1,23 @@
-Name:       capi-network-tethering
-Summary:    Tethering Framework
-Version:    0.0.9
-Release:    1
-Group:      TO_BE/FILLED_IN
-License:    TO_BE/FILLED_IN
-Source0:    %{name}-%{version}.tar.gz
-Requires(post):   /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
-
-BuildRequires: pkgconfig(dlog)
-BuildRequires: pkgconfig(dbus-glib-1)
-BuildRequires: pkgconfig(capi-base-common)
-BuildRequires: pkgconfig(glib-2.0)
-BuildRequires: pkgconfig(vconf)
-BuildRequires: cmake
+Name:          capi-network-tethering
+Summary:       Tethering Framework
+Version:       1.0.38
+Release:       1
+Group:         System/Network
+License:       Apache-2.0
+Source0:       %{name}-%{version}.tar.gz
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(dbus-1)
+BuildRequires: pkgconfig(capi-base-common)
+BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(gio-2.0)
+BuildRequires: pkgconfig(vconf)
+BuildRequires: pkgconfig(key-manager)
+BuildRequires: pkgconfig(libssl)
+BuildRequires: pkgconfig(capi-system-info)
+BuildRequires: pkgconfig(libtzplatform-config)
+BuildRequires: cmake
+Requires(post):                /sbin/ldconfig
+Requires(postun):      /sbin/ldconfig
 
 %description
 Tethering framework library for CAPI
@@ -28,15 +32,41 @@ Development package for Tethering framework library
 %prep
 %setup -q
 
+
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=/usr
+export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
+export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
+
+%cmake -DCMAKE_BUILD_TYPE="Private" \
+%if "%{?profile}" == "wearable"
+       -DTIZEN_WEARABLE=1 \
+%else
+%if "%{?profile}" == "mobile"
+       -DTIZEN_MOBILE=1 \
+%endif
+%endif
+%ifarch %{arm}
+       -DCMAKE_BUILD_TYPE="Private" -DARCH=arm \
+%else
+%if 0%{?simulator}
+       -DCMAKE_BUILD_TYPE="Private" -DARCH=emul \
+%else
+       -DCMAKE_BUILD_TYPE="Private" -DARCH=i586 \
+%endif
+%endif
+       .
+
+make %{?_smp_mflags}
 
-make %{?jobs:-j%jobs}
 
 %install
-rm -rf %{buildroot}
 %make_install
 
+mkdir -p %{buildroot}/usr/share/license
+cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering
+cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering-devel
+
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
@@ -45,33 +75,21 @@ rm -rf %{buildroot}
 %manifest capi-network-tethering.manifest
 %defattr(-,root,root,-)
 %{_libdir}/*.so.*
+/usr/share/license/capi-network-tethering
+%{_bindir}/tethering_test
+%ifarch %{arm}
+/etc/config/connectivity/sysinfo-tethering.xml
+%else
+%if 0%{?simulator}
+# Noop
+%else
+/etc/config/connectivity/sysinfo-tethering.xml
+%endif
+%endif
 
 %files devel
 %defattr(-,root,root,-)
 %{_includedir}/network/*.h
 %{_libdir}/pkgconfig/*.pc
 %{_libdir}/*.so
-
-%changelog
-* Fri Nov 02 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.9-1
-- Manifest file is added for SMACK
-
-* Mon Aug 20 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.8-1
-- Deprecated APIs are removed
-
-* Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.7-1
-- Managed APIs are implemented for Wi-Fi tethering settings
-
-* Sat Jul 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.6-1
-- Fix tethering callback issue (JIRA S1-6197)
-
-* Tue Jul 10 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.5
-- Getting MAC address API is implemented
-- TETHERING_TYPE_ALL case is implemented
-- Test code is implemented
-
-* Tue Jun 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.4
-- All internal APIs are implemented
-
-* Fri Jun 15 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.3
-- Deprecated API from Glib2-2.32.3 is replaced with new one
+/usr/share/license/capi-network-tethering-devel