Add new rpm package for test application #2
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
index 4ebf191..b87acb7 100644 (file)
@@ -1,6 +1,6 @@
 Name:          capi-network-tethering
 Summary:       Tethering Framework
-Version:       1.0.51
+Version:       1.0.56
 Release:       1
 Group:         System/Network
 License:       Apache-2.0
@@ -29,20 +29,20 @@ Requires:   %{name} = %{version}-%{release}
 %description devel
 Development package for Tethering framework library
 
+%package tool
+Summary:       Test application for Tethering
+%description tool
+Test application for Tethering
+
+
 %prep
 %setup -q
 
 
 %build
-%if "%{TIZEN_PROFILE_TV}" == "1"
-export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE -DTIZEN_TV_EXT"
-export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE -DTIZEN_TV_EXT"
-export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE -DTIZEN_TV_EXT"
-%else
 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
-%endif
 
 %cmake .
 
@@ -60,7 +60,6 @@ make %{?_smp_mflags}
 %manifest capi-network-tethering.manifest
 %defattr(-,root,root,-)
 %{_libdir}/*.so.*
-%{_bindir}/tethering_test
 %license LICENSE
 
 %files devel
@@ -69,3 +68,6 @@ make %{?_smp_mflags}
 %{_libdir}/pkgconfig/*.pc
 %{_libdir}/*.so
 %license LICENSE
+
+%files tool
+%{_bindir}/tethering_test