Fix the gcov build error
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
index 7e5c8c3..b5924dd 100644 (file)
@@ -1,19 +1,28 @@
-Name:       capi-network-tethering
-Summary:    Tethering Framework
-Version:    0.0.14
-Release:    1
-Group:      TO_BE/FILLED_IN
-License:    Apache-2.0
-Source0:    %{name}-%{version}.tar.gz
-Requires(post):   /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
-
-BuildRequires: pkgconfig(dlog)
-BuildRequires: pkgconfig(dbus-glib-1)
-BuildRequires: pkgconfig(capi-base-common)
-BuildRequires: pkgconfig(glib-2.0)
-BuildRequires: pkgconfig(vconf)
-BuildRequires: cmake
+Name:          capi-network-tethering
+Summary:       Tethering Framework
+Version:       1.2.2
+Release:       1
+Group:         System/Network
+License:       Apache-2.0
+Source0:       %{name}-%{version}.tar.gz
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(dbus-1)
+BuildRequires: pkgconfig(capi-base-common)
+BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(gio-2.0)
+BuildRequires: pkgconfig(vconf)
+BuildRequires: pkgconfig(key-manager)
+BuildRequires: pkgconfig(capi-system-info)
+BuildRequires: pkgconfig(libtzplatform-config)
+BuildRequires:  pkgconfig(gmock)
+BuildRequires: cmake
+%if 0%{?gcov:1}
+BuildRequires: gtest-devel
+BuildRequires: lcov
+BuildRequires: tar
+%endif
+Requires(post):                /sbin/ldconfig
+Requires(postun):      /sbin/ldconfig
 
 %description
 Tethering framework library for CAPI
@@ -25,24 +34,95 @@ Requires:   %{name} = %{version}-%{release}
 %description devel
 Development package for Tethering framework library
 
+%package tool
+Summary:       Test application for Tethering
+%description tool
+Test application for Tethering
+
+%if 0%{?gcov:1}
+%package gcov
+Summary:  Tethering Library(gcov)
+Group:    Network/Testing
+%description gcov
+gcov objects for coverage test
+%endif
+
+%if 0%{?asan} != 1
+%package unittests
+Summary: %{name} unittests binary
+
+%description unittests
+unittests binary
+%endif
+
 %prep
 %setup -q
 
+
 %build
-%ifarch %{arm}
-%cmake . -DARCH=arm
-%else
-%if 0%{?simulator}
-%cmake . -DARCH=emul
-%else
-%cmake . -DARCH=i586
+%if 0%{?gcov:1}
+export CFLAGS+=" -fprofile-arcs -ftest-coverage"
+export CXXFLAGS+=" -fprofile-arcs -ftest-coverage"
+export FFLAGS+=" -fprofile-arcs -ftest-coverage"
 %endif
+
+%if "%{?tizen_profile_name}" == "tv"
+export CFLAGS+=" -DTIZEN_TV_EXT"
+export CXXFLAGS+=" -DTIZEN_TV_EXT"
 %endif
-make %{?jobs:-j%jobs}
+
+%cmake -DLIB_INSTALL_DIR=%{_libdir} \
+       -DBUILD_UNITTEST=%{?asan:0}%{!?asan:1} \
+       .
+make %{?_smp_mflags}
 
 %install
+rm -rf %{buildroot}
 %make_install
 
+%if 0%{?gcov:1}
+builddir=$(basename $PWD)
+gcno_obj_dir=%{buildroot}%{_datadir}/gcov/obj/%{name}/"$builddir"
+mkdir -p "$gcno_obj_dir"
+find . -name '*.gcno' ! -path '*/tools/*' -exec cp --parents '{}' "$gcno_obj_dir" ';'
+%endif
+
+%if 0%{?asan} != 1
+cat << EOF > run-unittest.sh
+#!/bin/sh
+setup() {
+    echo "setup start"
+}
+
+test_main() {
+    echo "test_main start"
+    /usr/bin/tethering-gtest
+}
+
+teardown() {
+    echo "teardown start"
+}
+
+main() {
+    setup
+    test_main
+    teardown
+}
+
+main "\$*"
+EOF
+
+mkdir -p %{buildroot}%{_bindir}/tizen-unittests/%{name}
+install -m 0755 run-unittest.sh %{buildroot}%{_bindir}/tizen-unittests/%{name}/
+%endif
+
+%check
+%if 0%{?gcov:1}
+tests/tethering-gtest
+lcov -c --ignore-errors mismatch,graph,unused --no-external -b . -d . -o %{name}.info
+genhtml %{name}.info -o out --legend --show-details
+%endif
+
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
@@ -51,67 +131,25 @@ make %{?jobs:-j%jobs}
 %manifest capi-network-tethering.manifest
 %defattr(-,root,root,-)
 %{_libdir}/*.so.*
-%ifarch %{arm}
-/etc/config/connectivity/sysinfo-tethering.xml
-%else
-%if 0%{?simulator}
-# Noop
-%else
-/etc/config/connectivity/sysinfo-tethering.xml
-%endif
-%endif
+%license LICENSE
 
 %files devel
 %defattr(-,root,root,-)
 %{_includedir}/network/*.h
 %{_libdir}/pkgconfig/*.pc
 %{_libdir}/*.so
+%license LICENSE
 
-%changelog
-* Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.14-1
-- TETHERING_ERROR_NOT_PERMITTED is added
-- Implement connection timer
-- Reference count is used
-- Add API : tethering_xxx_ip_forward_status()
-- TETHERING_ERROR_NOT_SUPPORT_API is added for tethering_create()
-- TETHERING_ERROR_NOT_SUPPORT_API is returned when API is not supported
-- sysinfo-tethering.xml is installed depending on build machine
-
-* Sat Feb 16 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.13-1
-- Wrong linker flags are fixed
-- Add API : tethering_wifi_set_ssid()
-
-* Thu Feb 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.12-1
-- APIs are exported
-- LOG Format is changed
-- fvisibility=hidden is applied and API's return value is checked
-
-* Thu Jan 24 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.11-1
-- Indications for Wi-Fi tethering setting change are added
-- Dbus service / interface / object names are changed
-
-* Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.10-1
-- Wi-Fi tethering state is not checked when its settings are modified
+%files tool
+%{_bindir}/tethering_test
 
-* Fri Nov 02 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.9-1
-- Manifest file is added for SMACK
-
-* Mon Aug 20 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.8-1
-- Deprecated APIs are removed
-
-* Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.7-1
-- Managed APIs are implemented for Wi-Fi tethering settings
-
-* Sat Jul 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.6-1
-- Fix tethering callback issue (JIRA S1-6197)
-
-* Tue Jul 10 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.5
-- Getting MAC address API is implemented
-- TETHERING_TYPE_ALL case is implemented
-- Test code is implemented
-
-* Tue Jun 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.4
-- All internal APIs are implemented
+%if 0%{?gcov:1}
+%files gcov
+%{_datadir}/gcov/obj/*
+%endif
 
-* Fri Jun 15 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.3
-- Deprecated API from Glib2-2.32.3 is replaced with new one
+%if 0%{?asan} != 1
+%files unittests
+%{_bindir}/tethering-gtest
+%{_bindir}/tizen-unittests/%{name}/run-unittest.sh
+%endif