bug fix: Add address type to disable dbus method
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
index 5520407..924c0f4 100644 (file)
@@ -1,6 +1,6 @@
 Name:          capi-network-tethering
 Summary:       Tethering Framework
-Version:       1.0.45
+Version:       1.0.48
 Release:       1
 Group:         System/Network
 License:       Apache-2.0
@@ -44,17 +44,7 @@ export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
 %endif
 
-%cmake -DCMAKE_BUILD_TYPE="Private" \
-%ifarch %{arm}
-       -DCMAKE_BUILD_TYPE="Private" -DARCH=arm \
-%else
-%if 0%{?simulator}
-       -DCMAKE_BUILD_TYPE="Private" -DARCH=emul \
-%else
-       -DCMAKE_BUILD_TYPE="Private" -DARCH=i586 \
-%endif
-%endif
-       .
+%cmake .
 
 make %{?_smp_mflags}
 
@@ -71,21 +61,11 @@ make %{?_smp_mflags}
 %defattr(-,root,root,-)
 %{_libdir}/*.so.*
 %{_bindir}/tethering_test
-%license LICENSE.APLv2.0
-%ifarch %{arm}
-/etc/config/connectivity/sysinfo-tethering.xml
-%else
-%if 0%{?simulator}
-# Noop
-%else
-/etc/config/connectivity/sysinfo-tethering.xml
-%endif
-%endif
+%license LICENSE
 
 %files devel
 %defattr(-,root,root,-)
 %{_includedir}/network/*.h
 %{_libdir}/pkgconfig/*.pc
 %{_libdir}/*.so
-%license LICENSE.APLv2.0
-
+%license LICENSE