Modified checking supported feature function
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
index a3678f2..615375a 100644 (file)
@@ -1,6 +1,6 @@
 Name:          capi-network-tethering
 Summary:       Tethering Framework
-Version:       1.0.19
+Version:       1.0.26
 Release:       1
 Group:         System/Network
 License:       Apache-2.0
@@ -38,10 +38,10 @@ export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
 
 %cmake -DCMAKE_BUILD_TYPE="Private" \
-%if "%{?tizen_profile_name}" == "wearable"
+%if "%{?profile}" == "wearable"
        -DTIZEN_WEARABLE=1 \
 %else
-%if "%{?tizen_profile_name}" == "mobile"
+%if "%{?profile}" == "mobile"
        -DTIZEN_MOBILE=1 \
 %endif
 %endif
@@ -75,6 +75,7 @@ cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering-devel
 %defattr(-,root,root,-)
 %{_libdir}/*.so.*
 /usr/share/license/capi-network-tethering
+%{_bindir}/tethering_test
 %ifarch %{arm}
 /etc/config/connectivity/sysinfo-tethering.xml
 %else