Add LCOV comment for line coverage
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
index 7a10dd1..4ebf191 100644 (file)
@@ -1,6 +1,6 @@
 Name:          capi-network-tethering
 Summary:       Tethering Framework
-Version:       1.0.22
+Version:       1.0.51
 Release:       1
 Group:         System/Network
 License:       Apache-2.0
@@ -14,6 +14,7 @@ BuildRequires:        pkgconfig(vconf)
 BuildRequires: pkgconfig(key-manager)
 BuildRequires: pkgconfig(libssl)
 BuildRequires: pkgconfig(capi-system-info)
+BuildRequires: pkgconfig(libtzplatform-config)
 BuildRequires: cmake
 Requires(post):                /sbin/ldconfig
 Requires(postun):      /sbin/ldconfig
@@ -33,28 +34,17 @@ Development package for Tethering framework library
 
 
 %build
+%if "%{TIZEN_PROFILE_TV}" == "1"
+export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE -DTIZEN_TV_EXT"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE -DTIZEN_TV_EXT"
+export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE -DTIZEN_TV_EXT"
+%else
 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
-
-%cmake -DCMAKE_BUILD_TYPE="Private" \
-%if "%{?profile}" == "wearable"
-       -DTIZEN_WEARABLE=1 \
-%else
-%if "%{?profile}" == "mobile"
-       -DTIZEN_MOBILE=1 \
-%endif
-%endif
-%ifarch %{arm}
-       -DCMAKE_BUILD_TYPE="Private" -DARCH=arm \
-%else
-%if 0%{?simulator}
-       -DCMAKE_BUILD_TYPE="Private" -DARCH=emul \
-%else
-       -DCMAKE_BUILD_TYPE="Private" -DARCH=i586 \
 %endif
-%endif
-       .
+
+%cmake .
 
 make %{?_smp_mflags}
 
@@ -62,10 +52,6 @@ make %{?_smp_mflags}
 %install
 %make_install
 
-mkdir -p %{buildroot}/usr/share/license
-cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering
-cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering-devel
-
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
@@ -74,21 +60,12 @@ cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering-devel
 %manifest capi-network-tethering.manifest
 %defattr(-,root,root,-)
 %{_libdir}/*.so.*
-/usr/share/license/capi-network-tethering
 %{_bindir}/tethering_test
-%ifarch %{arm}
-/etc/config/connectivity/sysinfo-tethering.xml
-%else
-%if 0%{?simulator}
-# Noop
-%else
-/etc/config/connectivity/sysinfo-tethering.xml
-%endif
-%endif
+%license LICENSE
 
 %files devel
 %defattr(-,root,root,-)
 %{_includedir}/network/*.h
 %{_libdir}/pkgconfig/*.pc
 %{_libdir}/*.so
-/usr/share/license/capi-network-tethering-devel
+%license LICENSE