resetting manifest requested domain to floor
[platform/core/api/serial.git] / packaging / capi-network-serial.spec
index 6fa4dd5..f019120 100644 (file)
@@ -2,11 +2,10 @@ Name:       capi-network-serial
 Summary:    Network Serial Framework
 Version: 0.0.7
 Release:    0
-Group:      TO_BE/FILLED_IN
+Group:      API
 License:    Apache License, Version 2.0
 Source0:    %{name}-%{version}.tar.gz
-Requires(post): /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
+Source1001:    capi-network-serial.manifest
 
 BuildRequires:  pkgconfig(dbus-glib-1)
 BuildRequires:  pkgconfig(dlog)
@@ -21,7 +20,7 @@ Network Serial Framework
 
 %package devel
 Summary:    Network Serial Framework (DEV)
-Group:      TO_BE/FILLED
+Group:      API
 Requires:   %{name} = %{version}-%{release}
 
 %description devel
@@ -29,15 +28,15 @@ Network Serial Framework (DEV).
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
-cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
+%cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
 
 make %{?jobs:-j%jobs}
 
 %install
-rm -rf %{buildroot}
 %make_install
 
 
@@ -46,11 +45,12 @@ rm -rf %{buildroot}
 %postun -p /sbin/ldconfig
 
 %files
-%manifest capi-network-serial.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_libdir}/libcapi-network-serial.so.*
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_includedir}/network/serial.h
 %{_libdir}/pkgconfig/capi-network-serial.pc