Add some APIs to get and set cellular pdn type
[platform/core/api/connection.git] / packaging / capi-network-connection.spec
old mode 100644 (file)
new mode 100755 (executable)
index a8e029e..d85e002
@@ -1,6 +1,6 @@
 Name:          capi-network-connection
 Summary:       Network Connection library in TIZEN C API
-Version:       1.0.70
+Version:       1.0.83
 Release:       1
 Group:         System/Network
 License:       Apache-2.0
@@ -12,7 +12,6 @@ BuildRequires:        pkgconfig(network)
 BuildRequires: pkgconfig(glib-2.0)
 BuildRequires: pkgconfig(capi-base-common)
 BuildRequires: pkgconfig(capi-system-info)
-BuildRequires:  model-build-features
 Requires(post):                /sbin/ldconfig
 Requires(postun):      /sbin/ldconfig
 
@@ -32,20 +31,21 @@ Network Connection library in Tizen C API (Development)
 
 
 %build
-export CFLAGS+=' -Wno-unused-local-typedefs'
+export CFLAGS+=' -Wno-unused-local-typedefs -fprofile-arcs -ftest-coverage'
+export LDFLAGS+=' -lgcov'
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 cmake -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
        -DLIB_PATH=%{_lib} \
 %if 0%{?model_build_feature_network_dsds} == 1
        -DTIZEN_DUALSIM_ENABLE=1 \
 %endif
-%if "%{?tizen_profile_name}" == "wearable"
+%if "%{profile}" == "wearable"
        -DTIZEN_WEARABLE=1 \
 %else
-%if "%{?tizen_profile_name}" == "mobile"
+%if "%{profile}" == "mobile"
        -DTIZEN_MOBILE=1 \
 %else
-%if "%{?tizen_profile_name}" == "tv"
+%if "%{profile}" == "tv"
        -DTIZEN_TV=1 \
 %endif
 %endif