Merge branch 'tizen_devel' into tizen
[platform/core/api/mediavision.git] / packaging / capi-media-vision.spec
index f03666e..ca186f0 100644 (file)
@@ -1,6 +1,6 @@
 Name:        capi-media-vision
 Summary:     Media Vision library for Tizen Native API
-Version:     0.28.4
+Version:     0.28.5
 Release:     0
 Group:       Multimedia/Framework
 License:     Apache-2.0 and BSD-3-Clause
@@ -299,54 +299,8 @@ make %{?jobs:-j%jobs}
 
 %install
 
-cat << EOF > run-unittest.sh
-#!/bin/bash
-setup() {
-    echo "setup start"
-    mkdir /opt/usr/home/owner/media/Others/mv_test
-    pushd /opt/media/USBDriveA1/mv_test
-    tar -xzvf mv_test.tar.gz -C /opt/usr/home/owner/media/Others/mv_test
-    tar -xzvf open_model_zoo.tar.gz -C /opt/usr/home/owner/media/Others/mv_test/open_model_zoo
-    bash /opt/usr/home/owner/media/Others/mv_test/post_install_on_target.sh
-    popd
-}
-
-test_main() {
-    echo "test_main start"
-    /usr/bin/mv_test --gtest_filter=-*TestPoseLandmarkDetectionTflite.MobilenetV1*
-%if "%{enable_ml_face_recognition}" == "1"
-    /usr/bin/test_face_recognition
-%endif
-%if "%{enable_ml_image_classification}" == "1"
-    /usr/bin/test_image_classification
-%endif
-%if "%{enable_ml_object_detection}" == "1"
-    /usr/bin/test_object_detection
-%endif
-%if "%{enable_ml_object_detection_3d}" == "1"
-    /usr/bin/test_object_detection_3d
-%endif
-%if "%{enable_ml_landmark_detection}" == "1"
-    /usr/bin/test_landmark_detection
-%endif
-}
-
-teardown() {
-    echo "teardown start"
-    rm -rf /opt/usr/home/owner/media/Others/mv_test
-}
-
-main() {
-    setup
-    test_main
-    teardown
-}
-
-main "$@"
-EOF
-
 mkdir -p %{buildroot}%{_bindir}/tizen-unittests/%{name}
-install -m 0755 run-unittest.sh %{buildroot}%{_bindir}/tizen-unittests/%{name}
+install -m 0755 script/run-unittest.sh %{buildroot}%{_bindir}/tizen-unittests/%{name}
 
 %make_install
 
@@ -425,7 +379,6 @@ find . -name '*.gcno' -not -path "./test/*" -exec cp --parents '{}' "$gcno_obj_d
 %{_includedir}/media/mv_3d.h
 %{_includedir}/media/mv_3d_type.h
 %{_includedir}/media/mv_3d_internal.h
-%{_includedir}/media/mv_3d_private.h
 %{_libdir}/pkgconfig/*3d.pc
 %endif
 
@@ -453,6 +406,7 @@ find . -name '*.gcno' -not -path "./test/*" -exec cp --parents '{}' "$gcno_obj_d
 %endif
 %if "%{enable_ml_landmark_detection}" == "1"
 %{_datadir}/%{name}/facial_landmark.json
+%{_datadir}/%{name}/pose_landmark.json
 %{_libdir}/libmv_landmark_detection.so
 %endif
 
@@ -484,6 +438,8 @@ find . -name '*.gcno' -not -path "./test/*" -exec cp --parents '{}' "$gcno_obj_d
 %if "%{enable_ml_landmark_detection}" == "1"
 %{_includedir}/media/mv_facial_landmark_internal.h
 %{_includedir}/media/mv_facial_landmark_type.h
+%{_includedir}/media/mv_pose_landmark_internal.h
+%{_includedir}/media/mv_pose_landmark_type.h
 %{_libdir}/pkgconfig/*landmark-detection.pc
 %endif