[Release version 0.2.60] 1. Check api value to avoid array index overflow, 2. Block...
[platform/core/api/camera.git] / packaging / capi-media-camera.spec
index d296c70..6c2dc65 100644 (file)
@@ -3,7 +3,7 @@
 
 Name:       capi-media-camera
 Summary:    A Camera API
-Version:    0.2.45
+Version:    0.2.60
 Release:    0
 Group:      Multimedia/API
 License:    Apache-2.0
@@ -25,6 +25,9 @@ BuildRequires:  pkgconfig(ecore-wayland)
 %endif
 BuildRequires:  pkgconfig(libtbm)
 BuildRequires:  pkgconfig(tizen-extension-client)
+%if "%{?profile}" == "mobile" || "%{?profile}" == "common"
+BuildRequires:  pkgconfig(mm-evas-renderer)
+%endif
 
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
@@ -61,6 +64,11 @@ MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 %else
        -DWAYLAND_SUPPORT=Off \
 %endif
+%if "%{?profile}" == "mobile" || "%{?profile}" == "common"
+       -DEVAS_RENDERER_SUPPORT=On \
+%else
+       -DEVAS_RENDERER_SUPPORT=Off \
+%endif
 %if %{with x}
        -DX11_SUPPORT=On
 %else
@@ -90,5 +98,6 @@ cp LICENSE.APLv2 %{buildroot}%{_datadir}/license/%{name}
 
 %files devel
 %{_includedir}/media/camera.h
+%{_includedir}/media/camera_internal.h
 %{_libdir}/pkgconfig/*.pc
 %{_libdir}/libcapi-media-camera.so