Directory path migration
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
old mode 100755 (executable)
new mode 100644 (file)
index bfb0ac1..c639022
@@ -1,37 +1,46 @@
-#sbs-git:slp/api/location-manager capi-location-manager 0.1.0 d1ee09a32e8bc0e9ed48ece37c641a7393c086c5
-Name:       capi-location-manager
-Summary:    A Location Manager library in Tizen Native API
-Version: 0.1.7
-Release:    1
-Group:      System/Libraries
-License:    Apache Licensc, Version 2.0
-Source0:    %{name}-%{version}.tar.gz
-BuildRequires:  cmake
-BuildRequires:  pkgconfig(dlog)
-BuildRequires:  pkgconfig(location)
-BuildRequires:  pkgconfig(capi-base-common)
+Name: capi-location-manager
+Summary: A Location Manager library in Tizen Native API
+Version: 0.7.0
+Release: 1
+Group: Location/API
+License: Apache-2.0
+Source0: %{name}-%{version}.tar.gz
+Source1001: %{name}.manifest
+BuildRequires: cmake
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(lbs-location)
+BuildRequires: pkgconfig(capi-base-common)
+BuildRequires: pkgconfig(capi-system-info)
+BuildRequires: pkgconfig(vconf)
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
 %description
+A Location Manager library in Tizen Native API
 
 
 %package devel
 Summary:  A Location Manager library in Tizen Native API (Development)
-Group:    TO_BE/FILLED_IN
+Group:    Location/Development
 Requires: %{name} = %{version}-%{release}
 
 %description devel
-
+A Location Manager library in Tizen Native API (Development)
 
 
 %prep
 %setup -q
-
+cp %{SOURCE1001} .
 
 %build
+
+export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
+export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
+
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
-cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} -DINCLUDEDIR=%{_includedir} \
+-DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
 
 make %{?jobs:-j%jobs}
 
@@ -39,13 +48,16 @@ make %{?jobs:-j%jobs}
 rm -rf %{buildroot}
 %make_install
 
+#mkdir -p %{buildroot}/usr/share/license
+#cp LICENSE %{buildroot}/usr/share/license/%{name}
+
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
 
-
 %files
-%manifest capi-location-manager.manifest
+%manifest %{name}.manifest
+%license LICENSE
 %{_libdir}/libcapi-location-manager.so.*
 
 %files devel
@@ -54,3 +66,17 @@ rm -rf %{buildroot}
 %{_libdir}/libcapi-location-manager.so
 
 
+%if 1
+%package test
+Summary:    Test application of Location Manager
+Group:      Location/Testing
+Requires: %{name} = %{version}-%{release}
+
+%description test
+Test application of Location Manager
+
+%files test
+%manifest test/capi-location-manager-test.manifest
+#/usr/share/packages/capi-location-manager-test.xml
+/opt/usr/devel/location/location_test
+%endif