Directory path migration
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
old mode 100755 (executable)
new mode 100644 (file)
index 0e96a07..c639022
@@ -1,18 +1,23 @@
-Name:       capi-location-manager
-Summary:    A Location Manager library in Tizen Native API
-Version:    0.1.11
-Release:    0
-Group:      Location/API
-License:    Apache-2.0
-Source0:    %{name}-%{version}.tar.gz
-Source1001:     capi-location-manager.manifest
-BuildRequires:  cmake
-BuildRequires:  pkgconfig(dlog)
-BuildRequires:  pkgconfig(location)
-BuildRequires:  pkgconfig(capi-base-common)
+Name: capi-location-manager
+Summary: A Location Manager library in Tizen Native API
+Version: 0.7.0
+Release: 1
+Group: Location/API
+License: Apache-2.0
+Source0: %{name}-%{version}.tar.gz
+Source1001: %{name}.manifest
+BuildRequires: cmake
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(lbs-location)
+BuildRequires: pkgconfig(capi-base-common)
+BuildRequires: pkgconfig(capi-system-info)
+BuildRequires: pkgconfig(vconf)
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
 
 %description
-A Location Manager library in Tizen Native API package.
+A Location Manager library in Tizen Native API
+
 
 %package devel
 Summary:  A Location Manager library in Tizen Native API (Development)
@@ -20,21 +25,32 @@ Group:    Location/Development
 Requires: %{name} = %{version}-%{release}
 
 %description devel
-A Location Manager library in Tizen Native API (Development) package.
-%devel_desc
+A Location Manager library in Tizen Native API (Development)
+
 
 %prep
 %setup -q
 cp %{SOURCE1001} .
 
 %build
+
+export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
+export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
+
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
-%cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
-%__make %{?jobs:-j%jobs}
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} -DINCLUDEDIR=%{_includedir} \
+-DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
+
+make %{?jobs:-j%jobs}
 
 %install
+rm -rf %{buildroot}
 %make_install
 
+#mkdir -p %{buildroot}/usr/share/license
+#cp LICENSE %{buildroot}/usr/share/license/%{name}
+
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
@@ -45,7 +61,22 @@ MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 %{_libdir}/libcapi-location-manager.so.*
 
 %files devel
-%manifest %{name}.manifest
 %{_includedir}/location/*.h
 %{_libdir}/pkgconfig/*.pc
 %{_libdir}/libcapi-location-manager.so
+
+
+%if 1
+%package test
+Summary:    Test application of Location Manager
+Group:      Location/Testing
+Requires: %{name} = %{version}-%{release}
+
+%description test
+Test application of Location Manager
+
+%files test
+%manifest test/capi-location-manager-test.manifest
+#/usr/share/packages/capi-location-manager-test.xml
+/opt/usr/devel/location/location_test
+%endif