Remove unused code about test application
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
old mode 100755 (executable)
new mode 100644 (file)
index bfb0ac1..834bf7e
@@ -1,37 +1,43 @@
-#sbs-git:slp/api/location-manager capi-location-manager 0.1.0 d1ee09a32e8bc0e9ed48ece37c641a7393c086c5
-Name:       capi-location-manager
-Summary:    A Location Manager library in Tizen Native API
-Version: 0.1.7
-Release:    1
-Group:      System/Libraries
-License:    Apache Licensc, Version 2.0
-Source0:    %{name}-%{version}.tar.gz
-BuildRequires:  cmake
-BuildRequires:  pkgconfig(dlog)
-BuildRequires:  pkgconfig(location)
-BuildRequires:  pkgconfig(capi-base-common)
+Name: capi-location-manager
+Summary: A Location Manager library in Tizen Native API
+Version: 0.7.10
+Release: 1
+Group: Location/API
+License: Apache-2.0
+Source0: %{name}-%{version}.tar.gz
+Source1001: %{name}.manifest
+BuildRequires: cmake
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(lbs-location)
+BuildRequires: pkgconfig(capi-base-common)
+BuildRequires: pkgconfig(capi-system-info)
+BuildRequires: pkgconfig(vconf)
+BuildRequires: pkgconfig(libtzplatform-config)
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
 %description
+A Location Manager library in Tizen Native API
 
 
 %package devel
 Summary:  A Location Manager library in Tizen Native API (Development)
-Group:    TO_BE/FILLED_IN
+Group:    Location/Development
 Requires: %{name} = %{version}-%{release}
 
 %description devel
-
+A Location Manager library in Tizen Native API (Development)
 
 
 %prep
 %setup -q
-
+cp %{SOURCE1001} .
 
 %build
+
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
-cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} -DINCLUDEDIR=%{_includedir} \
+-DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} -DTZ_SYS_BIN=%{TZ_SYS_BIN} \
 
 make %{?jobs:-j%jobs}
 
@@ -43,14 +49,13 @@ rm -rf %{buildroot}
 
 %postun -p /sbin/ldconfig
 
-
 %files
-%manifest capi-location-manager.manifest
+%manifest %{name}.manifest
+%license LICENSE
 %{_libdir}/libcapi-location-manager.so.*
+%{_bindir}/location_test
 
 %files devel
 %{_includedir}/location/*.h
 %{_libdir}/pkgconfig/*.pc
 %{_libdir}/libcapi-location-manager.so
-
-