sync : [ACR-1070] Fused Location
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
index bf6e4a0..67f1652 100644 (file)
@@ -1,6 +1,6 @@
 Name: capi-location-manager
 Summary: A Location Manager library in Tizen Native API
-Version: 0.7.0
+Version: 0.8.0
 Release: 1
 Group: Location/API
 License: Apache-2.0
@@ -12,6 +12,7 @@ BuildRequires: pkgconfig(lbs-location)
 BuildRequires: pkgconfig(capi-base-common)
 BuildRequires: pkgconfig(capi-system-info)
 BuildRequires: pkgconfig(vconf)
+BuildRequires: pkgconfig(libtzplatform-config)
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
@@ -34,13 +35,9 @@ cp %{SOURCE1001} .
 
 %build
 
-export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
-export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
-export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
-
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} -DINCLUDEDIR=%{_includedir} \
--DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
+-DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} -DTZ_SYS_BIN=%{TZ_SYS_BIN} \
 
 make %{?jobs:-j%jobs}
 
@@ -48,9 +45,6 @@ make %{?jobs:-j%jobs}
 rm -rf %{buildroot}
 %make_install
 
-#mkdir -p %{buildroot}/usr/share/license
-#cp LICENSE %{buildroot}/usr/share/license/%{name}
-
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
@@ -59,24 +53,9 @@ rm -rf %{buildroot}
 %manifest %{name}.manifest
 %license LICENSE
 %{_libdir}/libcapi-location-manager.so.*
+%{_bindir}/location_test
 
 %files devel
 %{_includedir}/location/*.h
 %{_libdir}/pkgconfig/*.pc
 %{_libdir}/libcapi-location-manager.so
-
-
-%if 1
-%package test
-Summary:    Test application of Location Manager
-Group:      Location/Testing
-Requires: %{name} = %{version}-%{release}
-
-%description test
-Test application of Location Manager
-
-%files test
-%manifest test/capi-location-manager-test.manifest
-/usr/share/packages/capi-location-manager-test.xml
-/opt/usr/devel/location/location_test
-%endif