Test application enabled
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
old mode 100755 (executable)
new mode 100644 (file)
index 7842f31..62a9ced
@@ -1,6 +1,6 @@
 Name: capi-location-manager
 Summary: A Location Manager library in Tizen Native API
-Version: 0.6.3
+Version: 0.7.7
 Release: 1
 Group: Location/API
 License: Apache-2.0
@@ -12,6 +12,7 @@ BuildRequires: pkgconfig(lbs-location)
 BuildRequires: pkgconfig(capi-base-common)
 BuildRequires: pkgconfig(capi-system-info)
 BuildRequires: pkgconfig(vconf)
+BuildRequires: pkgconfig(libtzplatform-config)
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
@@ -40,7 +41,7 @@ export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
 
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} -DINCLUDEDIR=%{_includedir} \
--DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
+-DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} -DTZ_SYS_BIN=%{TZ_SYS_BIN} \
 
 make %{?jobs:-j%jobs}
 
@@ -48,9 +49,6 @@ make %{?jobs:-j%jobs}
 rm -rf %{buildroot}
 %make_install
 
-#mkdir -p %{buildroot}/usr/share/license
-#cp LICENSE %{buildroot}/usr/share/license/%{name}
-
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
@@ -77,6 +75,6 @@ Test application of Location Manager
 
 %files test
 %manifest test/capi-location-manager-test.manifest
-/usr/share/packages/capi-location-manager-test.xml
-/opt/usr/devel/location/location_test
+#%{TZ_SYS_RO_PACKAGES}/capi-location-manager-test.xml
+%{_bindir}/location_test
 %endif