Test application moved to location package
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
old mode 100755 (executable)
new mode 100644 (file)
index 2c77208..0471324
@@ -1,17 +1,18 @@
-Name:          capi-location-manager
-Summary:       A Location Manager library in Tizen Native API
-Version:       0.6.1
-Release:       1
-Group:         Location/API
-License:       Apache-2.0
-Source0:       %{name}-%{version}.tar.gz
+Name: capi-location-manager
+Summary: A Location Manager library in Tizen Native API
+Version: 0.7.8
+Release: 1
+Group: Location/API
+License: Apache-2.0
+Source0: %{name}-%{version}.tar.gz
 Source1001: %{name}.manifest
-BuildRequires:  cmake
-BuildRequires:  pkgconfig(dlog)
-BuildRequires:  pkgconfig(lbs-location)
-BuildRequires:  pkgconfig(capi-base-common)
-BuildRequires:  pkgconfig(capi-system-info)
-BuildRequires:  pkgconfig(vconf)
+BuildRequires: cmake
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(lbs-location)
+BuildRequires: pkgconfig(capi-base-common)
+BuildRequires: pkgconfig(capi-system-info)
+BuildRequires: pkgconfig(vconf)
+BuildRequires: pkgconfig(libtzplatform-config)
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
@@ -39,9 +40,8 @@ export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
 
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
-#cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} -DINCLUDEDIR=%{_includedir} \
--DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
+-DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} -DTZ_SYS_BIN=%{TZ_SYS_BIN} \
 
 make %{?jobs:-j%jobs}
 
@@ -49,9 +49,6 @@ make %{?jobs:-j%jobs}
 rm -rf %{buildroot}
 %make_install
 
-#mkdir -p %{buildroot}/usr/share/license
-#cp LICENSE %{buildroot}/usr/share/license/%{name}
-
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
@@ -60,6 +57,7 @@ rm -rf %{buildroot}
 %manifest %{name}.manifest
 %license LICENSE
 %{_libdir}/libcapi-location-manager.so.*
+%{_bindir}/location_test
 
 %files devel
 %{_includedir}/location/*.h
@@ -67,7 +65,7 @@ rm -rf %{buildroot}
 %{_libdir}/libcapi-location-manager.so
 
 
-%if 1
+%if 0
 %package test
 Summary:    Test application of Location Manager
 Group:      Location/Testing
@@ -78,6 +76,6 @@ Test application of Location Manager
 
 %files test
 %manifest test/capi-location-manager-test.manifest
-/usr/share/packages/capi-location-manager-test.xml
-/opt/usr/devel/location/location_test
+#%{TZ_SYS_RO_PACKAGES}/capi-location-manager-test.xml
+%{_bindir}/location_test
 %endif