Change the structure due to remove deprecated API
[platform/core/api/base-utils.git] / packaging / capi-base-utils.spec
index 0ac8647..2d501ed 100755 (executable)
@@ -1,6 +1,6 @@
 Name:       capi-base-utils
 Summary:    Base Utils
-Version:    1.2.4
+Version:    2.0.0
 Release:    1
 Group:      Base
 License:    Apache-2.0 and ICU
@@ -12,7 +12,7 @@ BuildRequires:  pkgconfig(dlog)
 
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
-       
+
 %description
 The base utils library for internationalization and localization
 
@@ -21,6 +21,11 @@ License:    Apache-2.0 and ICU
 Summary:    The Base Utils Library (Development)
 Group:      Base
 Requires:   %{name} = %{version}-%{release}
+Provides:   capi-base-utils-devel-profile_common = %{version}-%{release}
+Provides:   capi-base-utils-devel-profile_mobile = %{version}-%{release}
+Provides:   capi-base-utils-devel-profile_ivi = %{version}-%{release}
+Provides:   capi-base-utils-devel-profile_tv = %{version}-%{release}
+Provides:   capi-base-utils-devel-profile_wearable = %{version}-%{release}
 
 %description devel
 The base utils library for internationalization and localization (Development)
@@ -32,19 +37,6 @@ The base utils library for internationalization and localization (Development)
 #export CFLAGS="$CFLAGS -Wall -Werror -Wno-unused-function"
 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
     -DPKG_NAME=%{name} -DPKG_VERSION=%{version} \
-%if "%{profile}" == "wearable"
-    -DTIZEN_WEARABLE=YES \
-%endif
-%if "%{profile}" == "mobile"
-    -DTIZEN_MOBILE=YES \
-%endif
-%if "%{profile}" == "common"
-    -DTIZEN_MOBILE=YES \
-%endif
-%if "%{profile}" == "common_iot"
-    -DTIZEN_MOBILE=YES \
-%endif
-
 
 make %{?jobs:-j%jobs}