Release version 0.7.4
[platform/core/base/bundle.git] / packaging / bundle.spec
index d8c5017..fe7daa7 100644 (file)
@@ -1,11 +1,12 @@
 Name:       bundle
 Summary:    String key-val dictionary ADT
-Version:    0.4.0
+Version:    0.7.4
 Release:    0
 Group:      System/Libraries
 License:    Apache-2.0
 Source0:        bundle-%{version}.tar.gz
 Source1001:     bundle.manifest
+Source1002:     parcel.manifest
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(dlog)
@@ -51,9 +52,38 @@ Group:      Application Framework/Testing
 Simple string key-val dictionary ADT gcov objects
 %endif
 
+#################################################
+## parcel
+#################################################
+%package -n parcel
+Summary:    Parcel Library
+Group:      Development/Libraries
+
+%description -n parcel
+Parcel Library
+
+%package -n parcel-devel
+Summary:    Parcel Library (devel)
+Group:      Development/Libraries
+Requires:   parcel = %{version}-%{release}
+
+%description -n parcel-devel
+Parcel Library (devel)
+
+#################################################
+# parcel-unittests
+#################################################
+%package -n parcel-unittests
+Summary:    GTest for parcel
+Group:      Development/Libraries
+
+%description -n parcel-unittests
+GTest for parcel
+
 %prep
 %setup -q -n %{name}-%{version}
 cp %{SOURCE1001} .
+cp %{SOURCE1002} .
 
 %build
 %if 0%{?gcov:1}
@@ -72,7 +102,7 @@ find . -name '*.gcno' -exec cp '{}' gcov-obj ';'
 %endif
 
 %check
-ctest --output-on-failure %{?_smp_mflags}
+ctest --verbose %{?_smp_mflags}
 %if 0%{?gcov:1}
 lcov -c --ignore-errors graph --no-external -q -d . -o bundle.info
 genhtml bundle.info -o bundle.out
@@ -92,6 +122,12 @@ install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj
 
 %postun -p /sbin/ldconfig
 
+%post -n parcel
+/sbin/ldconfig
+
+%postun -n parcel
+/sbin/ldconfig
+
 %post unittests
 %if 0%{?gcov:1}
 %{_bindir}/bundle_unittests
@@ -123,3 +159,20 @@ install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj
 %files gcov
 %{_datadir}/gcov/*
 %endif
+
+#################################################
+# parcel
+#################################################
+%files -n parcel
+%manifest parcel.manifest
+%license LICENSE
+%{_libdir}/libparcel.so.*
+
+%files -n parcel-devel
+%manifest parcel.manifest
+%{_includedir}/*
+%{_libdir}/pkgconfig/parcel.pc
+%{_libdir}/libparcel.so
+
+%files -n parcel-unittests
+%{_bindir}/parcel_unittests