TDC Demo Preparation: Application Block
[tools/building-blocks.git] / packaging / building-blocks.spec
index 7a24020..f7d2626 100644 (file)
@@ -25,8 +25,9 @@ Source0:      %{name}-%{version}.tar.gz
 #Source1090:   domain-UIX.inc
 #Source1100:   domain-security.inc
 Source1200:    domain-apis.inc
+Source1210:    domain-csapis.inc
+Source1220:    domain-webapis.inc
 
-Source2001:    epicfeature-headless.inc
 Source2010:    epicfeature-development.inc
 Source2020:    epicfeature-platform.inc
 
@@ -72,6 +73,8 @@ In Tizen building blocks, "Requires" means mandatory package.
 %package       category-domains
 Summary:       Tizen Techinical Domains
 Suggests:      %{name}-root-domain_API
+Suggests:      %{name}-root-domain_CSAPI
+Suggests:      %{name}-root-domain_WebAPI
 %description   category-domains
 This meta package lists all Tizen blocks (meta packages) designating
 techinical domains.
@@ -81,10 +84,9 @@ techinical domains.
 
 %package       category-epicfeatures
 Summary:       Tizen Major Features
-Suggests:      %{name}-root-feature_Headless
-Suggests:      %{name}-root-feature_Headed
 Suggests:      %{name}-root-feature_Development
 Suggests:      %{name}-root-feature_Platform
+Suggests:      %{name}-root-feature_App
 %description   category-epicfeatures
 This meta package lists all Tizen blocks (meta packages) designating
 major features that are supposed to be orthogonal to each other
@@ -149,7 +151,24 @@ end}}
                elseif (string.sub(line, 1, 4) == 'boot') then \
                elseif (prefix == rpm.expand("%{2}")) then \
                        line = string.gsub(line, "-", "_")
-                       print("Suggests: "..rpm.expand("%{3}").."zblock_"..line) \
+                       print("Suggests: %{name}-"..rpm.expand("%{3}").."zblock_"..line) \
+                       print("\\n") \
+               end \
+       end \
+end}}
+
+
+# Requires the created suggests list of blocks with yaml file list
+# DIRECTORY, Prefix-To-Be-Removed, Prefix-for-block-name
+%define list_suggest_linkreq() %{expand:%{lua:if posix.access(rpm.expand("%{SOURCE1200}"), "f") then \
+       for f in posix.files(rpm.expand("%{1}")) do \
+               local line =  string.sub(f, string.len(rpm.expand("%{2}"))+2) \
+               local prefix = string.sub(f, 1, string.len(rpm.expand("%{2}"))) \
+               if (string.sub(line, 1, 10) == 'adaptation') then \
+               elseif (string.sub(line, 1, 4) == 'boot') then \
+               elseif (prefix == rpm.expand("%{2}")) then \
+                       line = string.gsub(line, "-", "_")
+                       print("Requires: %{name}-"..rpm.expand("%{3}").."zblock_"..line) \
                        print("\\n") \
                end \
        end \
@@ -169,7 +188,7 @@ end}}
                        local summary_available = 0 \
                        local filename = rpm.expand("%{1}").."/"..f \
                        print("\\n") \
-                       print("%%package "..pkg.."\\n") \
+                       print("%package "..pkg.."\\n") \
                        if posix.access(filename) then \
                                for tag in io.lines(filename) do \
                                        if (string.sub(tag, 1, 8) == "Summary:") then \
@@ -202,9 +221,9 @@ end}}
                        else \
                                print("Requires: CANNOT_FIND_REQUIRED_FILES\\n") \
                        end \
-                       print("%%description "..pkg.."\\n") \
+                       print("%description "..pkg.."\\n") \
                        print("Auto Generated Block (zblock) of "..f.."\\n") \
-                       print("%%files "..pkg.."\\n") \
+                       print("%files "..pkg.."\\n") \
                        print("\\n\\n\\n") \
                end \
        end \
@@ -225,12 +244,11 @@ python ./rule_checker.py
 
 ############## DOMAINS ##################
 %{include_if_mainbuild %{SOURCE1200}}
+%{include_if_mainbuild %{SOURCE1210}}
+%{include_if_mainbuild %{SOURCE1220}}
 
 ############## EPIC FEATURES ######################
 
-# Include "headless" epic feature. The script should not execute "include" if the contexts is in GBS service in OBS or GBS-Export
-%{include_if_mainbuild %{SOURCE2001}}
-
 # Dev tools
 %{include_if_mainbuild %{SOURCE2010}}