Code sync: merged tizen 2.4 base source code
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index 84779c2..f5c7e73 100644 (file)
@@ -1,14 +1,15 @@
 Name:       bluetooth-tools
 Summary:    Bluetooth-tools
 Version:    0.2.35
-Release:    3
+Release:    0
 Group:      Network & Connectivity/Bluetooth
 License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
-Source1001:    bluetooth-address.service
+Source1001: bluetooth-address.service
 BuildRequires:  cmake
-Requires:       bluetooth-tools-no-firmware
 Suggests:       bluetooth-share
+Requires:       tizen-platform-config-tools
+Requires :      bluetooth-tools-no-firmware
 
 %description
 Tools fo bluetooth run/stop and set address
@@ -17,7 +18,7 @@ Tools fo bluetooth run/stop and set address
 Summary:    On/Off Bluetooth adapter
 Group:      Network & Connectivity/Bluetooth
 Requires:   %{name} = %{version}-%{release}
-Requires: rfkill
+Requires:   rfkill
 Conflicts:  bluetooth-firmware-bcm
 
 %description no-firmware
@@ -30,8 +31,28 @@ On/Off bluetooth device
 export CFLAGS+=" -fpie -fvisibility=hidden"
 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
 
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
-make %{?jobs:-j%jobs}
+%if "%{profile}" == "mobile"
+export CFLAGS="$CFLAGS -DTIZEN_MOBILE"
+%elseif "%{profile}" == "wearable"
+export CFLAGS="$CFLAGS -DTIZEN_WEARABLE"
+%endif
+
+%cmake \
+%if "%{profile}" == "mobile"
+       -DTIZEN_MOBILE=YES \
+       -DTIZEN_WEARABLE=NO \
+%elseif "%{profile}" == "wearable"
+       -DTIZEN_MOBILE=NO \
+        -DTIZEN_WEARABLE=YES \
+%else
+        -DTIZEN_MOBILE=NO \
+        -DTIZEN_WEARABLE=NO \
+%endif
+
+%cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+%__make %{?_smp_mflags}
+#cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+#make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
@@ -49,6 +70,7 @@ ln -s ../bluetooth-address.service %{buildroot}%{_unitdir}/multi-user.target.wan
 mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
 install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
 install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
+install -D -m 0644 LICENSE.APLv2 %{buildroot}%{_datadir}/license/bluetooth-tools
 
 %files
 %manifest %{name}.manifest
@@ -63,7 +85,9 @@ install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-de
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
-
+%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
+%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hcidump.sh
+%{_datadir}/license/bluetooth-tools
 %{_unitdir}/multi-user.target.wants/bluetooth-address.service
 %{_unitdir}/bluetooth-address.service