Add the scripts for IVI profile
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index a441e5d..c8a4ade 100644 (file)
@@ -1,6 +1,6 @@
 Name:       bluetooth-tools
 Summary:    Bluetooth-tools
-Version:    0.2.35
+Version:    0.2.37
 Release:    0
 Group:      Network & Connectivity/Bluetooth
 License:    Apache-2.0
@@ -9,7 +9,7 @@ Source1001: bluetooth-address.service
 BuildRequires:  cmake
 Suggests:       bluetooth-share
 Requires:       tizen-platform-config-tools
-Requires :      bluetooth-tools-no-firmware
+Requires:      bluetooth-scripts
 
 %description
 Tools fo bluetooth run/stop and set address
@@ -19,6 +19,7 @@ Summary:    On/Off Bluetooth adapter
 Group:      Network & Connectivity/Bluetooth
 Requires:   %{name} = %{version}-%{release}
 Requires:   rfkill
+Provides:   bluetooth-scripts
 Conflicts:  bluetooth-firmware-bcm
 
 %description no-firmware
@@ -29,6 +30,7 @@ On/Off bluetooth device
 
 %build
 export CFLAGS+=" -fpie -fvisibility=hidden"
+export CXXFLAGS+=" -fpie -fvisibility=hidden"
 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
 
 %if "%{profile}" == "mobile"
@@ -43,13 +45,22 @@ export CFLAGS="$CFLAGS -DTIZEN_WEARABLE"
 %if "%{profile}" == "mobile"
        -DTIZEN_MOBILE=YES \
        -DTIZEN_WEARABLE=NO \
+       -DTIZEN_IVI=NO \
 %else
 %if "%{profile}" == "wearable"
        -DTIZEN_MOBILE=NO \
         -DTIZEN_WEARABLE=YES \
+       -DTIZEN_IVI=NO \
 %else
+%if "%{profile}" == "ivi"
         -DTIZEN_MOBILE=NO \
         -DTIZEN_WEARABLE=NO \
+       -DTIZEN_IVI=YES \
+%else
+        -DTIZEN_MOBILE=NO \
+        -DTIZEN_WEARABLE=NO \
+       -DTIZEN_IVI=NO \
+%endif
 %endif
 %endif
 
@@ -79,7 +90,7 @@ install -D -m 0644 LICENSE.APLv2 %{buildroot}%{_datadir}/license/bluetooth-tools
 %files
 %manifest %{name}.manifest
 %defattr(-,root,root,-)
-%if "%{profile}" == "mobile"
+%if "%{profile}" == "mobile" || "%{profile}" == "wearable" || "%{profile}" == "ivi"
 %exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
 %else
 %{_sysconfdir}/rc.d/init.d/bluetooth-address
@@ -95,6 +106,9 @@ install -D -m 0644 LICENSE.APLv2 %{buildroot}%{_datadir}/license/bluetooth-tools
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hcidump.sh
+%if "%{profile}" == "mobile"
+%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-stack-down-with-radio.sh
+%endif
 %{_datadir}/license/bluetooth-tools
 %{_unitdir}/multi-user.target.wants/bluetooth-address.service
 %{_unitdir}/bluetooth-address.service