Add the scripts for IVI profile
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index 8f31541..c8a4ade 100644 (file)
@@ -1,23 +1,73 @@
 Name:       bluetooth-tools
-Summary:    bluetooth-tools
-Version:    0.2.35
-Release:    2
-Group:      TO_BE/FILLED_IN
-License:    Apache License, Version 2.0
+Summary:    Bluetooth-tools
+Version:    0.2.37
+Release:    0
+Group:      Network & Connectivity/Bluetooth
+License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
-Source1001:    bluetooth-address.service
+Source1001: bluetooth-address.service
 BuildRequires:  cmake
+Suggests:       bluetooth-share
+Requires:       tizen-platform-config-tools
+Requires:      bluetooth-scripts
 
 %description
 Tools fo bluetooth run/stop and set address
 
+%package no-firmware
+Summary:    On/Off Bluetooth adapter
+Group:      Network & Connectivity/Bluetooth
+Requires:   %{name} = %{version}-%{release}
+Requires:   rfkill
+Provides:   bluetooth-scripts
+Conflicts:  bluetooth-firmware-bcm
+
+%description no-firmware
+On/Off bluetooth device
 
 %prep
 %setup -q
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
-make %{?jobs:-j%jobs}
+export CFLAGS+=" -fpie -fvisibility=hidden"
+export CXXFLAGS+=" -fpie -fvisibility=hidden"
+export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
+
+%if "%{profile}" == "mobile"
+export CFLAGS="$CFLAGS -DTIZEN_MOBILE"
+%else
+%if "%{profile}" == "wearable"
+export CFLAGS="$CFLAGS -DTIZEN_WEARABLE"
+%endif
+%endif
+
+%cmake \
+%if "%{profile}" == "mobile"
+       -DTIZEN_MOBILE=YES \
+       -DTIZEN_WEARABLE=NO \
+       -DTIZEN_IVI=NO \
+%else
+%if "%{profile}" == "wearable"
+       -DTIZEN_MOBILE=NO \
+        -DTIZEN_WEARABLE=YES \
+       -DTIZEN_IVI=NO \
+%else
+%if "%{profile}" == "ivi"
+        -DTIZEN_MOBILE=NO \
+        -DTIZEN_WEARABLE=NO \
+       -DTIZEN_IVI=YES \
+%else
+        -DTIZEN_MOBILE=NO \
+        -DTIZEN_WEARABLE=NO \
+       -DTIZEN_IVI=NO \
+%endif
+%endif
+%endif
+
+%cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+%__make %{?_smp_mflags}
+#cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+#make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
@@ -28,15 +78,23 @@ mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc5.d
 ln -s %{_sysconfdir}/rc.d/init.d/bluetooth-address %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
 ln -s %{_sysconfdir}/rc.d/init.d/bluetooth-address %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
 
-mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
-install -m 0644 %{SOURCE1001} %{buildroot}%{_libdir}/systemd/system/
-ln -s ../bluetooth-address.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/bluetooth-address.service
+mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
+install -m 0644 %{SOURCE1001} %{buildroot}%{_unitdir}
+ln -s ../bluetooth-address.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-address.service
 
+mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
+install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
+install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
+install -D -m 0644 LICENSE.APLv2 %{buildroot}%{_datadir}/license/bluetooth-tools
 
 %files
-%manifest bluetooth-tools.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
+%if "%{profile}" == "mobile" || "%{profile}" == "wearable" || "%{profile}" == "ivi"
+%exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
+%else
 %{_sysconfdir}/rc.d/init.d/bluetooth-address
+%endif
 %{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
 %{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-stack-up.sh
@@ -46,6 +104,17 @@ ln -s ../bluetooth-address.service %{buildroot}%{_libdir}/systemd/system/multi-u
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
-%{_libdir}/systemd/system/multi-user.target.wants/bluetooth-address.service
-%{_libdir}/systemd/system/bluetooth-address.service
+%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
+%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hcidump.sh
+%if "%{profile}" == "mobile"
+%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-stack-down-with-radio.sh
+%endif
+%{_datadir}/license/bluetooth-tools
+%{_unitdir}/multi-user.target.wants/bluetooth-address.service
+%{_unitdir}/bluetooth-address.service
 
+%files no-firmware
+%manifest %{name}.manifest
+%defattr(-, root, root)
+%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
+%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh