Increase the version to 8.0
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index f2d5613..5e6797e 100644 (file)
@@ -1,7 +1,7 @@
 Name:       bluetooth-tools
 Summary:    Bluetooth-tools
-Version:    0.2.37
-Release:    0
+Version:    0.8.0
+Release:    1
 Group:      Network & Connectivity/Bluetooth
 License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
@@ -9,7 +9,6 @@ Source0:    %{name}-%{version}.tar.gz
 BuildRequires:  cmake
 Suggests:       bluetooth-share
 Requires:       tizen-platform-config-tools
-Requires:      bluetooth-scripts
 Requires:   %{name}-compat = %{version}-%{release}
 Recommends:   %{name}-profile_common = %{version}-%{release}
 
@@ -57,8 +56,6 @@ Bluetooth-tools extension for Tizen ivi profile.
 Summary:    On/Off Bluetooth adapter
 Group:      Network & Connectivity/Bluetooth
 Requires:   %{name} = %{version}-%{release}
-Requires:   rfkill
-Provides:   bluetooth-scripts
 Conflicts:  bluetooth-firmware-bcm
 
 %description no-firmware
@@ -91,25 +88,23 @@ mkdir -p %{buildroot}/run/bluetooth
 install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
 install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
 
-install -D -m 0644 packaging/bluez-start.service %{buildroot}%{_libdir}/systemd/system/bluez-start.service
+install -D -m 0644 packaging/bluetooth-stack-up.service %{buildroot}%{_unitdir}/bluetooth-stack-up.service
 
-install -D -m 0644 packaging/bluetooth-stack-up.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-up.service
+install -D -m 0644 packaging/bluetooth-stack-down.service %{buildroot}%{_unitdir}/bluetooth-stack-down.service
 
-install -D -m 0644 packaging/bluetooth-stack-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.service
+install -D -m 0644 packaging/bluetooth-stack-down-with-radio.service %{buildroot}%{_unitdir}/bluetooth-stack-down-with-radio.service
 
-install -D -m 0644 packaging/bluetooth-stack-down-with-radio.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
+#install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_unitdir}/bluetooth-force-hci-logger.service
+#install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_unitdir}/bluetooth-hci-dump@.service
 
-#install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
-#install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-dump@.service
+install -D -m 0644 packaging/bluetooth-hci-up.service %{buildroot}%{_unitdir}/bluetooth-hci-up.service
+install -D -m 0644 packaging/bluetooth-hci-down.service %{buildroot}%{_unitdir}/bluetooth-hci-down.service
 
-install -D -m 0644 packaging/bluetooth-hci-up.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-up.service
-install -D -m 0644 packaging/bluetooth-hci-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-down.service
-
-install -D -m 0644 packaging/bluetooth-stack-up-common.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-up-common.service
-install -D -m 0644 packaging/bluetooth-stack-down-common.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-common.service
+install -D -m 0644 packaging/bluetooth-stack-up-common.service %{buildroot}%{_unitdir}/bluetooth-stack-up-common.service
+install -D -m 0644 packaging/bluetooth-stack-down-common.service %{buildroot}%{_unitdir}/bluetooth-stack-down-common.service
 
 %post
-mkdir -p %{_libdir}/systemd/system/multi-user.target.wants/
+mkdir -p %{_unitdir}/multi-user.target.wants/
 
 %files
 %manifest %{name}.manifest
@@ -146,11 +141,10 @@ popd
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-reset-env.sh
-%{_libdir}/systemd/system/bluetooth-stack-up-common.service
-%{_libdir}/systemd/system/bluetooth-stack-down-common.service
-%{_libdir}/systemd/system/bluez-start.service
-%{_libdir}/systemd/system/bluetooth-hci-up.service
-%{_libdir}/systemd/system/bluetooth-hci-down.service
+%{_unitdir}/bluetooth-stack-up-common.service
+%{_unitdir}/bluetooth-stack-down-common.service
+%{_unitdir}/bluetooth-hci-up.service
+%{_unitdir}/bluetooth-hci-down.service
 
 %post profile_mobile
 pushd %{_prefix}/etc/bluetooth/
@@ -172,12 +166,11 @@ popd
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
-%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
-%{_libdir}/systemd/system/bluez-start.service
-%{_libdir}/systemd/system/bluetooth-stack-up.service
-%{_libdir}/systemd/system/bluetooth-stack-down.service
-%{_libdir}/systemd/system/bluetooth-hci-up.service
-%{_libdir}/systemd/system/bluetooth-hci-down.service
+%{_unitdir}/bluetooth-stack-down-with-radio.service
+%{_unitdir}/bluetooth-stack-up.service
+%{_unitdir}/bluetooth-stack-down.service
+%{_unitdir}/bluetooth-hci-up.service
+%{_unitdir}/bluetooth-hci-down.service
 
 %post profile_ivi
 pushd %{_prefix}/etc/bluetooth/
@@ -196,11 +189,10 @@ popd
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-reset-env.sh
-%{_libdir}/systemd/system/bluez-start.service
-%{_libdir}/systemd/system/bluetooth-stack-up.service
-%{_libdir}/systemd/system/bluetooth-stack-down.service
-%{_libdir}/systemd/system/bluetooth-hci-up.service
-%{_libdir}/systemd/system/bluetooth-hci-down.service
+%{_unitdir}/bluetooth-stack-up.service
+%{_unitdir}/bluetooth-stack-down.service
+%{_unitdir}/bluetooth-hci-up.service
+%{_unitdir}/bluetooth-hci-down.service
 
 %post profile_wearable
 pushd %{_prefix}/etc/bluetooth/
@@ -219,11 +211,10 @@ popd
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-reset-env.sh
-%{_libdir}/systemd/system/bluez-start.service
-%{_libdir}/systemd/system/bluetooth-stack-up.service
-%{_libdir}/systemd/system/bluetooth-stack-down.service
-%{_libdir}/systemd/system/bluetooth-hci-up.service
-%{_libdir}/systemd/system/bluetooth-hci-down.service
+%{_unitdir}/bluetooth-stack-up.service
+%{_unitdir}/bluetooth-stack-down.service
+%{_unitdir}/bluetooth-hci-up.service
+%{_unitdir}/bluetooth-hci-down.service
 
 %files no-firmware
 %manifest %{name}.manifest
@@ -231,9 +222,8 @@ popd
 %defattr(-, root, root)
 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh
-%{_libdir}/systemd/system/bluez-start.service
-%{_libdir}/systemd/system/bluetooth-stack-up.service
-%{_libdir}/systemd/system/bluetooth-stack-down.service
-%{_libdir}/systemd/system/bluetooth-hci-up.service
-%{_libdir}/systemd/system/bluetooth-hci-down.service
+%{_unitdir}/bluetooth-stack-up.service
+%{_unitdir}/bluetooth-stack-down.service
+%{_unitdir}/bluetooth-hci-up.service
+%{_unitdir}/bluetooth-hci-down.service