Add the service file for controlling bluetooth rfkill
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index d256a59..1f051b4 100644 (file)
@@ -97,6 +97,12 @@ install -D -m 0644 packaging/bluetooth-hci-logger.path %{buildroot}%{_libdir}/sy
 install -D -m 0644 packaging/bluetooth-hci-logger-stop.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
 install -D -m 0644 packaging/bluetooth-hci-logger-stop.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
 
+install -D -m 0644 packaging/bluetooth-rfkill-unblock.service %{buildroot}%{_libdir}/systemd/system/bluetooth-rfkill-unblock.service
+install -D -m 0644 packaging/bluetooth-rfkill-unblock.path %{buildroot}%{_libdir}/systemd/system/bluetooth-rfkill-unblock.path
+
+install -D -m 0644 packaging/bluetooth-rfkill-block.service %{buildroot}%{_libdir}/systemd/system/bluetooth-rfkill-block.service
+install -D -m 0644 packaging/bluetooth-rfkill-block.path %{buildroot}%{_libdir}/systemd/system/bluetooth-rfkill-block.path
+
 install -D -m 0644 packaging/bluez-start.service %{buildroot}%{_libdir}/systemd/system/bluez-start.service
 install -D -m 0644 packaging/bluez-start.path %{buildroot}%{_libdir}/systemd/system/bluez-start.path
 
@@ -111,6 +117,12 @@ mkdir -p %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger.path
 
+ln -sf %{_libdir}/systemd/system/bluetooth-rfkill-unblock.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
+ln -sf %{_libdir}/systemd/system/bluetooth-rfkill-unblock.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-rfkill-unblock.path
+
+ln -sf %{_libdir}/systemd/system/bluetooth-rfkill-block.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
+ln -sf %{_libdir}/systemd/system/bluetooth-rfkill-block.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-rfkill-block.path
+
 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger-stop.path
 
@@ -140,6 +152,10 @@ ln -sf %{_libdir}/systemd/system/bluetooth-force-hci-logger.service %{_sysconfdi
 #%{_unitdir}/bluetooth-address.service
 %{_libdir}/systemd/system/bluetooth-hci-logger.service
 %{_libdir}/systemd/system/bluetooth-hci-logger.path
+%{_libdir}/systemd/system/bluetooth-rfkill-unblock.service
+%{_libdir}/systemd/system/bluetooth-rfkill-unblock.path
+%{_libdir}/systemd/system/bluetooth-rfkill-block.service
+%{_libdir}/systemd/system/bluetooth-rfkill-block.path
 %{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
 %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
 %{_libdir}/systemd/system/bluez-start.service