Install bluetooth-stack-down-with-radio.service in the mobile profile
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index 64c35ea..02c99f7 100644 (file)
@@ -103,6 +103,9 @@ install -D -m 0644 packaging/bluez-start.path %{buildroot}%{_libdir}/systemd/sys
 install -D -m 0644 packaging/bluetooth-stack-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.service
 install -D -m 0644 packaging/bluetooth-stack-down.path %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.path
 
+install -D -m 0644 packaging/bluetooth-stack-down-with-radio.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
+install -D -m 0644 packaging/bluetooth-stack-down-with-radio.path %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.path
+
 install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
 install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-dump@.service
 
@@ -179,6 +182,9 @@ ln -sf mobile/bt-stack-up.sh bt-stack-up.sh
 ln -sf mobile/bt-stack-down.sh bt-stack-down.sh
 ln -sf mobile/bt-stack-down-with-radio.sh bt-stack-down-with-radio.sh
 ln -sf mobile/bt-reset-env.sh bt-reset-env.sh
+ln -sf %{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
+ln -sf %{_libdir}/systemd/system/bluetooth-stack-down-with-radio.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-stack-down-with-radio.path
+ln -sf %{_libdir}/systemd/system/bluetooth-stack-down-with-radio.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 popd
 %preun profile_mobile
 pushd %{_prefix}/etc/bluetooth/
@@ -193,6 +199,8 @@ popd
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
+%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
+%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.path
 
 %post profile_ivi
 pushd %{_prefix}/etc/bluetooth/