Fix SAM tool violations (GlobalVariable)
[platform/core/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
index d200c7e..af160ad 100644 (file)
@@ -5,10 +5,11 @@
 %bcond_with x
 %define _dumpdir /opt/etc/dump.d/module.d
 %define _varlibdir /opt/var/lib
+%define _meshdir /opt/usr/mesh
 
 Name:       bluetooth-frwk
 Summary:    Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
-Version:    0.3.0
+Version:    0.6.0
 Release:    1
 Group:      Network & Connectivity/Bluetooth
 License:    Apache-2.0
@@ -22,6 +23,8 @@ Requires: bluetooth-tools
 %define bt_permanent_log DISABLED
 %define bt_http_proxy DISABLED
 %define bt_factory_mode DISABLED
+%define bt_avc_target ENABLED
+%define bt_vendor_operation DISABLED
 
 BuildRequires:  pkgconfig(aul)
 %if %{bt_factory_mode} == ENABLED
@@ -46,6 +49,8 @@ BuildRequires:  cmake
 BuildRequires:  pkgconfig(cynara-client)
 BuildRequires:  pkgconfig(cynara-creds-gdbus)
 BuildRequires:  pkgconfig(libtzplatform-config)
+BuildRequires:  pkgconfig(json-c)
+BuildRequires:  pkgconfig(ell)
 BuildRequires:  pkgconfig(storage)
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-appfw-app-control)
@@ -59,7 +64,7 @@ Requires(postun): /sbin/ldconfig
 
 %description
 Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
- This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
+This package contains API set for BT GAP, BT SDP, BT RFCOMM and BLE Mesh.
 
 %package profile_common
 Summary:    bluetooth-frwk service and conf files for common profile
@@ -283,6 +288,15 @@ export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_HTTP_PROXY"
 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_FACTORY_MODE"
 %endif
 
+%if %{bt_avc_target} == ENABLED
+export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_AVC_TARGET"
+%endif
+
+%if %{bt_vendor_operation} == ENABLED
+export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_VENDOR_OPERATION"
+%endif
+
+
 %ifarch %{ix86} x86_64
 export CFLAGS+=" -DTIZEN_TEST_EMUL"
 export CXXFLAGS+=" -DTIZEN_TEST_EMUL"
@@ -377,6 +391,7 @@ mkdir -p %{buildroot}%{_unitdir}/starter.target.wants
 mkdir -p %{buildroot}%{_unitdir}/delayed.target.wants
 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
 mkdir -p %{buildroot}/%{_prefix}/lib/udev/rules.d
+mkdir -p %{buildroot}%{_meshdir}
 
 cp packaging/99-bluetooth-rfkill.rules %{buildroot}/%{_prefix}/lib/udev/rules.d/99-bluetooth-rfkill.rules
 
@@ -419,6 +434,7 @@ ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/starter.target.wants/blu
 %post service
 /usr/bin/chsmack -a '_' %{_varlibdir}/bluetooth/auto-pair-blacklist
 /usr/bin/chown network_fw:network_fw %{_varlibdir}/bluetooth/auto-pair-blacklist
+/usr/bin/chown network_fw:network_fw %{_meshdir}
 
 %files
 %manifest %{name}.manifest
@@ -438,6 +454,7 @@ ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/starter.target.wants/blu
 %{_includedir}/bt-service/bluetooth-ipsp-api.h
 %{_includedir}/bt-service/bluetooth-gatt-server-api.h
 %{_includedir}/bt-service/bluetooth-gatt-client-api.h
+%{_includedir}/bt-service/bluetooth-mesh-api.h
 %{_libdir}/pkgconfig/bluetooth-api.pc
 %{_libdir}/libbluetooth-api.so
 
@@ -467,6 +484,7 @@ popd
 %{_bindir}/bluetooth-frwk-test
 %{_varlibdir}/bluetooth
 %{_prefix}/etc/bluetooth
+%{_meshdir}
 %attr(-,network_fw,network_fw) %{_varlibdir}/bluetooth/auto-pair-blacklist
 
 %if %{bt_http_proxy} == ENABLED