Mesh: Create mesh directory for configuration files
[platform/core/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
index aeec88c..6db9d7e 100644 (file)
@@ -5,6 +5,7 @@
 %bcond_with x
 %define _dumpdir /opt/etc/dump.d/module.d
 %define _varlibdir /opt/var/lib
+%define _meshdir /opt/usr/mesh
 
 Name:       bluetooth-frwk
 Summary:    Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
@@ -63,7 +64,7 @@ Requires(postun): /sbin/ldconfig
 
 %description
 Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
- This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
+This package contains API set for BT GAP, BT SDP, BT RFCOMM and BLE Mesh.
 
 %package profile_common
 Summary:    bluetooth-frwk service and conf files for common profile
@@ -390,6 +391,7 @@ mkdir -p %{buildroot}%{_unitdir}/starter.target.wants
 mkdir -p %{buildroot}%{_unitdir}/delayed.target.wants
 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
 mkdir -p %{buildroot}/%{_prefix}/lib/udev/rules.d
+mkdir -p %{buildroot}%{_meshdir}
 
 cp packaging/99-bluetooth-rfkill.rules %{buildroot}/%{_prefix}/lib/udev/rules.d/99-bluetooth-rfkill.rules
 
@@ -432,6 +434,7 @@ ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/starter.target.wants/blu
 %post service
 /usr/bin/chsmack -a '_' %{_varlibdir}/bluetooth/auto-pair-blacklist
 /usr/bin/chown network_fw:network_fw %{_varlibdir}/bluetooth/auto-pair-blacklist
+/usr/bin/chown network_fw:network_fw %{_meshdir}
 
 %files
 %manifest %{name}.manifest
@@ -481,6 +484,7 @@ popd
 %{_bindir}/bluetooth-frwk-test
 %{_varlibdir}/bluetooth
 %{_prefix}/etc/bluetooth
+%{_meshdir}
 %attr(-,network_fw,network_fw) %{_varlibdir}/bluetooth/auto-pair-blacklist
 
 %if %{bt_http_proxy} == ENABLED