Modify the package name for bluetooth-haltests
[platform/core/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
index a531270..4503076 100644 (file)
@@ -40,6 +40,7 @@ BuildRequires:  pkgconfig(libtzplatform-config)
 BuildRequires:  pkgconfig(storage)
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-appfw-app-control)
+BuildRequires:  pkgconfig(gmock)
 
 Requires(post): /usr/bin/vconftool
 Requires(post): /sbin/ldconfig
@@ -181,6 +182,14 @@ Requires:   %{name} = %{version}-%{release}
 %description plugin-headed
 This package is Bluetooth plugin to manage UI and syspopup
 
+%package -n bluetooth-haltests
+Summary: HAL Test package for bluetooth OAL
+Group:   TO_BE/FILLED
+Requires: %{name} = %{version}-%{release}
+
+%description -n bluetooth-haltests
+This package is C-API test application.
+
 %prep
 %setup -q
 cp %{SOURCE1001} .
@@ -385,7 +394,7 @@ ln -sf %{_libdir}/systemd/system/bluetooth-frwk-core.service %{_sysconfdir}/syst
 
 %post service
 /usr/bin/chsmack -a '_' %{_varlibdir}/bluetooth/auto-pair-blacklist
-/usr/bin/chown 5001:100 %{_varlibdir}/bluetooth/auto-pair-blacklist
+/usr/bin/chown network_fw:network_fw %{_varlibdir}/bluetooth/auto-pair-blacklist
 
 %files
 %manifest %{name}.manifest
@@ -434,7 +443,7 @@ popd
 %{_bindir}/bluetooth-frwk-test
 %{_varlibdir}/bluetooth
 %{_prefix}/etc/bluetooth
-%attr(-,owner,users) %{_varlibdir}/bluetooth/auto-pair-blacklist
+%attr(-,network_fw,network_fw) %{_varlibdir}/bluetooth/auto-pair-blacklist
 
 %files httpproxy
 %manifest %{name}.manifest
@@ -487,7 +496,8 @@ mv bluetooth-frwk.service bluetooth-frwk.service.common
 popd
 %files profile_common
 %license LICENSE
-%{_unitdir}/starter.target.wants/bluetooth-frwk.service
+%{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
+%exclude %{_unitdir}/starter.target.wants/bluetooth-frwk.service
 %{_unitdir}/bluetooth-frwk.service.common
 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
 
@@ -586,3 +596,7 @@ popd
 %if %{bt_bluez_hal} == ENABLED
 %{_libdir}/libbluetooth.default.so*
 %endif
+
+%files -n bluetooth-haltests
+%manifest %{name}.manifest
+%{_bindir}/bluetooth-haltests