Correct the pbap service file's path
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
index 1c4f4a2..64ac68f 100644 (file)
@@ -104,12 +104,13 @@ install -D -m 0644 LICENSE %{buildroot}%{_datadir}/license/bluetooth-agent
 #%if 0%{?sec_product_feature_bt_map_server_enable}
 install -D -m 0644 packaging/bluetooth-map-agent.service %{buildroot}%{_libdir}/systemd/user/bluetooth-map-agent.service
 #%endif
-
+install -D -m 0644 packaging/bluetooth-pbap-agent.service %{buildroot}%{_libdir}/systemd/system/bluetooth-pbap-agent.service
 
 %post
 %if 0%{?sec_product_feature_bt_map_server_enable}
 ln -sf %{_libdir}/systemd/user/bluetooth-map-agent.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 %endif
+ln -sf %{_libdir}/systemd/system/bluetooth-pbap-agent.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 
 %files
 %manifest %{name}.manifest
@@ -118,6 +119,7 @@ ln -sf %{_libdir}/systemd/user/bluetooth-map-agent.service %{_sysconfdir}/system
 %{_bindir}/bluetooth-hf-agent
 %{_datadir}/dbus-1/system-services/org.bluez.hf_agent.service
 %exclude %{_libdir}/systemd/user/bluetooth-map-agent.service
+%exclude %{_libdir}/systemd/system/bluetooth-pbap-agent.service
 %else
 %{_bindir}/bluetooth-ag-agent
 %{_bindir}/bluetooth-map-agent
@@ -130,5 +132,6 @@ ln -sf %{_libdir}/systemd/user/bluetooth-map-agent.service %{_sysconfdir}/system
 %attr(0666,-,-) /var/lib/bluetooth/voice-recognition-blacklist
 %{_sysconfdir}/dbus-1/system.d/bluetooth-ag-agent.conf
 %{_libdir}/systemd/user/bluetooth-map-agent.service
+%{_libdir}/systemd/system/bluetooth-pbap-agent.service
 %endif
 %{_datadir}/license/bluetooth-agent