Increase the version to 9.0
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
index 81da085..54bd990 100644 (file)
@@ -2,7 +2,7 @@
 
 Name:       bluetooth-agent
 Summary:    Bluetooth agent packages that support various external profiles
-Version:    0.6.0
+Version:    0.9.0
 Release:    1
 Group:      Network & Connectivity/Bluetooth
 License:    Apache-2.0
@@ -25,7 +25,7 @@ BuildRequires:  pkgconfig(capi-appfw-app-manager)
 BuildRequires:  pkgconfig(capi-system-device)
 %endif
 # This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
+%if "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && !0%{?_with_da_profile:1}
 # Original: common, mobile, tv. Added: "undefined"
 BuildRequires:  pkgconfig(contacts-service2)
 BuildRequires:  pkgconfig(msg-service)
@@ -71,12 +71,14 @@ Group:      Network & Connectivity/Bluetooth
 %description hfp_hf
 Bluetooth agent binary compiled for HFP(Hands-Free Profile)'s HF(Hands-Free) role
 
+%if !0%{?_with_da_profile:1}
 %package map
 Summary:       Bluetooth agent for MAP(Message Access Profile) server
 Requires:   %{name} = %{version}-%{release}
 Group:      Network & Connectivity/Bluetooth
 %description map
 Bluetooth agent binary compiled for MAP(Message Access Profile) server
+%endif
 
 %package pbap
 Summary:       Bluetooth agent for PBAP(PhoneBook Access Profile) server
@@ -117,7 +119,7 @@ export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_MEDIA_ENHANCE"
 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_HFP_AG"
 export CFLAGS="$CFLAGS -DTIZEN_SUPPORT_DUAL_HF"
 
-%ifarch aarch64 x86_64
+%ifarch aarch64 x86_64 riscv64
 echo arch64
 export CFLAGS+=" -DARCH64"
 export CXXFLAGS+=" -DARCH64"
@@ -142,7 +144,8 @@ export LDFLAGS+=" -lgcov"
 %cmake . -DCMAKE_INSTALL_PREFIX=/usr \
        -DTIZEN_FEATURE_BT_HFP_AG=1 \
        -DBUILD_GTESTS=%{?gcov:1}%{!?gcov:0} \
-       -DBUILD_GCOV=%{?gcov:1}%{!?gcov:0}
+       -DBUILD_GCOV=%{?gcov:1}%{!?gcov:0} \
+       -DDA_PROFILE=%{?_with_da_profile:1}%{!?_with_da_profile:0}
 
 make VERBOSE=1
 
@@ -155,8 +158,7 @@ find . -name '*.gcno' -exec cp '{}' gcov-obj ';'
 rm -rf %{buildroot}
 %make_install
 
-mkdir -p %{buildroot}%{_libdir}/systemd/system/
-mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/
+mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants/
 
 # This usage of profile macro does NOT conflict 4.0 configurability.
 #%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
@@ -168,11 +170,14 @@ mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/
 #install -D -m 0644 %{buildroot}/usr/bin/bluetooth-hf-agent %{buildroot}%{_bindir}/
 #install -D -m 0644 %{buildroot}/usr/bin/bluetooth-ipsp-agent %{buildroot}%{_bindir}/
 #%endif
+%if !0%{?_with_da_profile:1}
 install -D -m 0644 packaging/bluetooth-map-agent.service %{buildroot}%{_unitdir}/bluetooth-map-agent.service
+%endif
 install -D -m 0644 packaging/bluetooth-pbap-agent.service %{buildroot}%{_unitdir}/bluetooth-pbap-agent.service
 install -D -m 0644 packaging/bluetooth-ag-agent.service %{buildroot}%{_unitdir}/bluetooth-ag-agent.service
 install -D -m 0644 packaging/bluetooth-hf-agent.service %{buildroot}%{_unitdir}/bluetooth-hf-agent.service
 install -D -m 0644 packaging/bluetooth-hid-agent.service %{buildroot}%{_unitdir}/bluetooth-hid-agent.service
+ln -s ../bluetooth-hf-agent.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-hf-agent.service
 
 %if 0%{?gcov:1}
 mkdir -p %{buildroot}%{_datadir}/gcov/obj/%{name}
@@ -186,9 +191,6 @@ pushd unittest
 popd
 %endif
 
-install -D -m 0644 packaging/bluetooth-hf-agent.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hf-agent.service
-ln -s ../bluetooth-hf-agent.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hf-agent.service
-
 %files
 %manifest %{name}.manifest
 %license LICENSE
@@ -215,11 +217,11 @@ ln -s ../bluetooth-hf-agent.service %{buildroot}%{_libdir}/systemd/system/multi-
 %{_datadir}/dbus-1/system-services/org.bluez.hf_agent.service
 %{_sysconfdir}/dbus-1/system.d/bluetooth-hf-agent.conf
 %{_unitdir}/bluetooth-hf-agent.service
+%{_unitdir}/multi-user.target.wants/bluetooth-hf-agent.service
 #%exclude %{_unitdir}/bluetooth-map-agent.service
 #%exclude %{_unitdir}/bluetooth-pbap-agent.service
-%{_libdir}/systemd/system/bluetooth-hf-agent.service
-%{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hf-agent.service
 
+%if !0%{?_with_da_profile:1}
 %files map
 %manifest %{name}.manifest
 %license LICENSE
@@ -227,6 +229,7 @@ ln -s ../bluetooth-hf-agent.service %{buildroot}%{_libdir}/systemd/system/multi-
 %{_datadir}/dbus-1/system-services/org.bluez.map_agent.service
 %{_unitdir}/bluetooth-map-agent.service
 %{_sysconfdir}/dbus-1/system.d/bluetooth_map_agent.conf
+%endif
 
 %files pbap
 %manifest %{name}.manifest