Disable map-agent in DA profile
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
index 3b5b413..5211e43 100644 (file)
@@ -25,7 +25,7 @@ BuildRequires:  pkgconfig(capi-appfw-app-manager)
 BuildRequires:  pkgconfig(capi-system-device)
 %endif
 # This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
+%if "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && !0%{?_with_da_profile:1}
 # Original: common, mobile, tv. Added: "undefined"
 BuildRequires:  pkgconfig(contacts-service2)
 BuildRequires:  pkgconfig(msg-service)
@@ -71,12 +71,14 @@ Group:      Network & Connectivity/Bluetooth
 %description hfp_hf
 Bluetooth agent binary compiled for HFP(Hands-Free Profile)'s HF(Hands-Free) role
 
+%if !0%{?_with_da_profile:1}
 %package map
 Summary:       Bluetooth agent for MAP(Message Access Profile) server
 Requires:   %{name} = %{version}-%{release}
 Group:      Network & Connectivity/Bluetooth
 %description map
 Bluetooth agent binary compiled for MAP(Message Access Profile) server
+%endif
 
 %package pbap
 Summary:       Bluetooth agent for PBAP(PhoneBook Access Profile) server
@@ -142,7 +144,8 @@ export LDFLAGS+=" -lgcov"
 %cmake . -DCMAKE_INSTALL_PREFIX=/usr \
        -DTIZEN_FEATURE_BT_HFP_AG=1 \
        -DBUILD_GTESTS=%{?gcov:1}%{!?gcov:0} \
-       -DBUILD_GCOV=%{?gcov:1}%{!?gcov:0}
+       -DBUILD_GCOV=%{?gcov:1}%{!?gcov:0} \
+       -DDA_PROFILE=%{?_with_da_profile:1}%{!?_with_da_profile:0}
 
 make VERBOSE=1
 
@@ -167,7 +170,9 @@ mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants/
 #install -D -m 0644 %{buildroot}/usr/bin/bluetooth-hf-agent %{buildroot}%{_bindir}/
 #install -D -m 0644 %{buildroot}/usr/bin/bluetooth-ipsp-agent %{buildroot}%{_bindir}/
 #%endif
+%if !0%{?_with_da_profile:1}
 install -D -m 0644 packaging/bluetooth-map-agent.service %{buildroot}%{_unitdir}/bluetooth-map-agent.service
+%endif
 install -D -m 0644 packaging/bluetooth-pbap-agent.service %{buildroot}%{_unitdir}/bluetooth-pbap-agent.service
 install -D -m 0644 packaging/bluetooth-ag-agent.service %{buildroot}%{_unitdir}/bluetooth-ag-agent.service
 install -D -m 0644 packaging/bluetooth-hf-agent.service %{buildroot}%{_unitdir}/bluetooth-hf-agent.service
@@ -216,6 +221,7 @@ popd
 #%exclude %{_unitdir}/bluetooth-map-agent.service
 #%exclude %{_unitdir}/bluetooth-pbap-agent.service
 
+%if !0%{?_with_da_profile:1}
 %files map
 %manifest %{name}.manifest
 %license LICENSE
@@ -223,6 +229,7 @@ popd
 %{_datadir}/dbus-1/system-services/org.bluez.map_agent.service
 %{_unitdir}/bluetooth-map-agent.service
 %{_sysconfdir}/dbus-1/system.d/bluetooth_map_agent.conf
+%endif
 
 %files pbap
 %manifest %{name}.manifest