Increase the version to 7.5
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
index da3f618..3b5b413 100644 (file)
@@ -2,7 +2,7 @@
 
 Name:       bluetooth-agent
 Summary:    Bluetooth agent packages that support various external profiles
-Version:    0.1.3
+Version:    0.7.5
 Release:    1
 Group:      Network & Connectivity/Bluetooth
 License:    Apache-2.0
@@ -11,6 +11,7 @@ Source1001:   bluetooth-agent.manifest
 
 BuildRequires:  pkgconfig(aul)
 BuildRequires:  pkgconfig(bluetooth-api)
+BuildRequires:  pkgconfig(capi-media-audio-io)
 
 # The profile macro usage with the following comments may be removed after
 # Tizen OBS build projects are merged. However, each vendor may keep using
@@ -31,7 +32,7 @@ BuildRequires:  pkgconfig(msg-service)
 BuildRequires:  pkgconfig(email-service)
 %endif
 BuildRequires:  pkgconfig(capi-system-info)
-BuildRequires:  pkgconfig(dbus-glib-1)
+BuildRequires:  pkgconfig(dbus-1)
 BuildRequires:  pkgconfig(tapi)
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(vconf)
@@ -45,45 +46,64 @@ BuildRequires:  pkgconfig(libexif)
 BuildRequires:  pkgconfig(gio-2.0)
 BuildRequires:  cmake
 Requires: security-config
-Requires:      %{name}-compat = %{version}-%{release}
-Recommends:    %{name}-profile_common = %{version}-%{release}
+%if 0%{?gcov:1}
+BuildRequires:  gtest-devel
+BuildRequires:  lcov
+%endif
+
+#Requires:     %{name}-compat = %{version}-%{release}
+#Recommends:   %{name}-profile_common = %{version}-%{release}
 
 %description
 Bluetooth agent packages that support various external profiles
 
-%package profile_common
-Summary:       Bluetooth agent for common/tv/mobile
-Provides:      %{name}-compat = %{version}-%{release}
-Provides:      %{name}-profile_mobile = %{version}-%{release}
-Provides:      %{name}-profile_tv = %{version}-%{release}
-Conflicts:     %{name}-profile_ivi
-Conflicts:     %{name}-profile_wearable
-%description profile_common
-Bluetooth agent binary compiled for common, tv, mobile profiles
-
-%package profile_ivi
-Summary:       Bluetooth agent for ivi
-Provides:      %{name}-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_common
-Conflicts:     %{name}-profile_wearable
-%description profile_ivi
-Bluetooth agent binary compiled for ivi profile
-
-%package profile_wearable
-Summary:       Bluetooth agent for wearable
-Provides:      %{name}-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_common
-Conflicts:     %{name}-profile_ivi
-%description profile_wearable
-Bluetooth agent binary compiled for wearable profile
+%package hfp_ag
+Summary:       Bluetooth agent for HFP(Hands-Free Profile)'s AG(Audio Gate) role
+Requires:   %{name} = %{version}-%{release}
+Group:      Network & Connectivity/Bluetooth
+%description hfp_ag
+Bluetooth agent binary compiled for HFP(Hands-Free Profile)'s AG(Audio Gate) role
 
-%package ipsp
-Summary:    Bluetooth Ipsp daemon
+%package hfp_hf
+Summary:       Bluetooth agent for HFP(Hands-Free Profile)'s HF(Hands-Free) role
+Requires:   %{name} = %{version}-%{release}
 Group:      Network & Connectivity/Bluetooth
+%description hfp_hf
+Bluetooth agent binary compiled for HFP(Hands-Free Profile)'s HF(Hands-Free) role
+
+%package map
+Summary:       Bluetooth agent for MAP(Message Access Profile) server
+Requires:   %{name} = %{version}-%{release}
+Group:      Network & Connectivity/Bluetooth
+%description map
+Bluetooth agent binary compiled for MAP(Message Access Profile) server
+
+%package pbap
+Summary:       Bluetooth agent for PBAP(PhoneBook Access Profile) server
 Requires:   %{name} = %{version}-%{release}
+Group:      Network & Connectivity/Bluetooth
+%description pbap
+Bluetooth agent binary compiled for PBAP(PhoneBook Access Profile) server
 
+%package hid
+Summary:       Bluetooth agent for HID(Human Interface Device)'s device role
+Requires:   %{name} = %{version}-%{release}
+Group:      Network & Connectivity/Bluetooth
+%description hid
+Bluetooth agent binary compiled for HID(Human Interface Device)'s device role
+
+%package ipsp
+Summary:       Bluetooth agent for IPSP(Internet Protocol Support Profile)
+Requires:   %{name} = %{version}-%{release}
+Group:      Network & Connectivity/Bluetooth
 %description ipsp
-This package is Bluetooth ipsp daemon to manage activation / deactivation.
+Bluetooth agent binary compiled for IPSP(Internet Protocol Support Profile)
+
+%package tool
+Summary:       Test Application for HF
+
+%description tool
+Test Application for HF
 
 %prep
 %setup -q
@@ -93,24 +113,17 @@ cp %{SOURCE1001} .
 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
-#export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_MEDIA_ENHANCE"
+export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_MEDIA_ENHANCE"
 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_HFP_AG"
 export CFLAGS="$CFLAGS -DTIZEN_SUPPORT_DUAL_HF"
 
-%ifarch aarch64
+%ifarch aarch64 x86_64 riscv64
 echo arch64
 export CFLAGS+=" -DARCH64"
 export CXXFLAGS+=" -DARCH64"
 export FFLAGS+=" -DARCH64"
 %endif
 
-%ifarch x86_64
-echo x86_64
-export CFLAGS+=" -DARCH64"
-export CXXFLAGS+=" -DARCH64"
-export FFLAGS+=" -DARCH64"
-%endif
-
 export CFLAGS+=" -fpie -DTIZEN_FEATURE_BP_PBAP_SIM -fvisibility=hidden "
 export CXXFLAGS+=" -fpie -DTIZEN_FEATURE_BP_PBAP_SIM -fvisibility=hidden "
 
@@ -118,146 +131,121 @@ export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=
 
 export CFLAGS_DEFAULT="$CFLAGS"
 
-# This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
-# Original: wearable, ivi. Added: common, "undefined"
-
-# Build Wearable
-export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_PROFILE_WEARABLE"
-export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_LUNAR_DEVICE"
-mkdir -p wearable_build
-pushd wearable_build
-cmake .. -DCMAKE_INSTALL_PREFIX=/usr/wearable -DTIZEN_PROFILE_WEARABLE=1 -DTIZEN_FEATURE_BT_HFP_AG=1
-make VERBOSE=1
-popd
-
-
-# Build IVI
-# TODO: BT-Agent Developers, Please Check if TIZEN_KIRAN is really need for ALL NON-WEARABLES.
-export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_BT_KIRAN_DEVICE"
-export CFLAGS="$CFLAGS -DTIZEN_PROFILE_IVI"
-mkdir -p ivi_build
-pushd ivi_build
-cmake .. -DCMAKE_INSTALL_PREFIX=/usr/ivi -DTIZEN_PROFILE_WEARABLE=0 -DTIZEN_PROFILE_IVI=1 -DTIZEN_FEATURE_BT_HFP_AG=1
-make VERBOSE=1
-popd
-
+%if 0%{?gcov:1}
+export CFLAGS+=" -fprofile-arcs -ftest-coverage"
+export CXXFLAGS+=" -fprofile-arcs -ftest-coverage"
+export FFLAGS+=" -fprofile-arcs -ftest-coverage"
+export LDFLAGS+=" -lgcov"
 %endif
 
+# Build All (wearalbe/ivi/common/tv/mobile)
+%cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+       -DTIZEN_FEATURE_BT_HFP_AG=1 \
+       -DBUILD_GTESTS=%{?gcov:1}%{!?gcov:0} \
+       -DBUILD_GCOV=%{?gcov:1}%{!?gcov:0}
 
-# This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
-# Original: common, mobile, tv. Added: "undefined"
-
-# Build All Others (common/tv/mobile)
-# TODO: BT-Agent Developers, Please Check if TIZEN_KIRAN is really need for ALL NON-WEARABLES.
-export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_BT_KIRAN_DEVICE"
-mkdir -p common_build
-pushd common_build
-cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DTIZEN_PROFILE_WEARABLE=0 -DTIZEN_FEATURE_BT_HFP_AG=1
 make VERBOSE=1
-popd
 
+%if 0%{?gcov:1}
+mkdir -p gcov-obj
+find . -name '*.gcno' -exec cp '{}' gcov-obj ';'
 %endif
 
 %install
 rm -rf %{buildroot}
-# This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
-# Original: wearable, ivi. Added: common, "undefined"
-pushd wearable_build
-%make_install
-popd
-pushd ivi_build
 %make_install
-popd
-%endif
 
-# This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
-# Original: common, mobile, tv. Added: "undefined"
-pushd common_build
-%make_install
-popd
-%endif
+mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants/
 
-install -D -m 0644 packaging/bluetooth-map-agent.service %{buildroot}%{_libdir}/systemd/user/bluetooth-map-agent.service
 # This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
+#%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
 # Original: wearable, ivi. Added: common, "undefined"
-mkdir -p %{buildroot}%{_datadir}/dbus-1/system-services
-mkdir -p %{buildroot}%{_bindir}/
-install -D -m 0644 %{buildroot}/usr/wearable/share/dbus-1/system-services/org.bluez.hf_agent.service %{buildroot}%{_datadir}/dbus-1/system-services/
-install -D -m 0644 %{buildroot}/usr/wearable/share/dbus-1/system-services/org.projectx.bt_ipsp.service %{buildroot}%{_datadir}/dbus-1/system-services/
-install -D -m 0644 %{buildroot}/usr/wearable/bin/bluetooth-hf-agent %{buildroot}%{_bindir}/
-install -D -m 0644 %{buildroot}/usr/wearable/bin/bt-ipsp %{buildroot}%{_bindir}/
-install -D -m 0644 %{buildroot}/usr/ivi/share/dbus-1/system-services/org.projectx.bt_ipsp.service %{buildroot}%{_datadir}/dbus-1/system-services/
-install -D -m 0644 %{buildroot}/usr/ivi/bin/bluetooth-hf-agent %{buildroot}%{_bindir}/bluetooth-hf-agent.ivi
-install -D -m 0644 %{buildroot}/usr/ivi/bin/bt-ipsp %{buildroot}%{_bindir}/
-rm -Rf %{buildroot}/usr/ivi
-rm -Rf %{buildroot}/usr/wearable
+#mkdir -p %{buildroot}%{_datadir}/dbus-1/system-services
+#mkdir -p %{buildroot}%{_bindir}/
+#install -D -m 0644 %{buildroot}/usr/share/dbus-1/system-services/org.bluez.hf_agent.service %{buildroot}%{_datadir}/dbus-1/system-services/
+#install -D -m 0644 %{buildroot}/usr/share/dbus-1/system-services/org.bluez.ipsp_agent.service %{buildroot}%{_datadir}/dbus-1/system-services/
+#install -D -m 0644 %{buildroot}/usr/bin/bluetooth-hf-agent %{buildroot}%{_bindir}/
+#install -D -m 0644 %{buildroot}/usr/bin/bluetooth-ipsp-agent %{buildroot}%{_bindir}/
+#%endif
+install -D -m 0644 packaging/bluetooth-map-agent.service %{buildroot}%{_unitdir}/bluetooth-map-agent.service
+install -D -m 0644 packaging/bluetooth-pbap-agent.service %{buildroot}%{_unitdir}/bluetooth-pbap-agent.service
+install -D -m 0644 packaging/bluetooth-ag-agent.service %{buildroot}%{_unitdir}/bluetooth-ag-agent.service
+install -D -m 0644 packaging/bluetooth-hf-agent.service %{buildroot}%{_unitdir}/bluetooth-hf-agent.service
+install -D -m 0644 packaging/bluetooth-hid-agent.service %{buildroot}%{_unitdir}/bluetooth-hid-agent.service
+ln -s ../bluetooth-hf-agent.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-hf-agent.service
+
+%if 0%{?gcov:1}
+mkdir -p %{buildroot}%{_datadir}/gcov/obj/%{name}
+install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj/%{name}/
 %endif
-install -D -m 0644 packaging/bluetooth-pbap-agent.service %{buildroot}%{_libdir}/systemd/system/bluetooth-pbap-agent.service
 
-%post
-%if 0%{?sec_product_feature_bt_map_server_enable}
-ln -sf %{_libdir}/systemd/user/bluetooth-map-agent.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
-%endif
-ln -sf %{_libdir}/systemd/system/bluetooth-pbap-agent.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
-
-# This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
-# Original: wearable, ivi. Added: common, "undefined"
-%post profile_ivi
-ln -sf bluetooth-hf-agent.ivi %{_bindir}/bluetooth-hf-agent
-%preun profile_ivi
-rm %{_bindir}/bluetooth-hf-agent
+%check
+%if 0%{?gcov:1}
+pushd unittest
+./run_coverage.sh
+popd
 %endif
 
 %files
 %manifest %{name}.manifest
 %license LICENSE
 %defattr(-, root, root)
+%exclude %{_bindir}/gtest-bluetooth-agent
+%exclude %{_libdir}/lib*
+%exclude %{_datadir}/gcov/obj/*
 
-# This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
-# Original: wearable, ivi. Added: common, "undefined"
-%files profile_wearable
+%files hfp_ag
+%manifest %{name}.manifest
 %license LICENSE
-%{_bindir}/bluetooth-hf-agent
-%{_datadir}/dbus-1/system-services/org.bluez.hf_agent.service
-%exclude %{_libdir}/systemd/user/bluetooth-map-agent.service
-%exclude %{_libdir}/systemd/system/bluetooth-pbap-agent.service
+%{_bindir}/bluetooth-ag-agent
+%attr(0666,-,-) /var/lib/bluetooth/voice-recognition-blacklist
+%{_datadir}/dbus-1/system-services/org.bluez.ag_agent.service
+%{_sysconfdir}/dbus-1/system.d/bluetooth-ag-agent.conf
+%{_unitdir}/bluetooth-ag-agent.service
+#%exclude %{_unitdir}/bluetooth-map-agent.service
+#%exclude %{_unitdir}/bluetooth-pbap-agent.service
 
-%files profile_ivi
+%files hfp_hf
+%manifest %{name}.manifest
 %license LICENSE
-%{_bindir}/bluetooth-hf-agent.ivi
+%{_bindir}/bluetooth-hf-agent
 %{_datadir}/dbus-1/system-services/org.bluez.hf_agent.service
-%exclude %{_libdir}/systemd/user/bluetooth-map-agent.service
-%exclude %{_libdir}/systemd/system/bluetooth-pbap-agent.service
-%endif
+%{_sysconfdir}/dbus-1/system.d/bluetooth-hf-agent.conf
+%{_unitdir}/bluetooth-hf-agent.service
+%{_unitdir}/multi-user.target.wants/bluetooth-hf-agent.service
+#%exclude %{_unitdir}/bluetooth-map-agent.service
+#%exclude %{_unitdir}/bluetooth-pbap-agent.service
 
-# This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
-# Original: common, mobile, tv. Added: "undefined"
-%files profile_common
+%files map
+%manifest %{name}.manifest
 %license LICENSE
-%{_bindir}/bluetooth-ag-agent
 %{_bindir}/bluetooth-map-agent
+%{_datadir}/dbus-1/system-services/org.bluez.map_agent.service
+%{_unitdir}/bluetooth-map-agent.service
+%{_sysconfdir}/dbus-1/system.d/bluetooth_map_agent.conf
+
+%files pbap
+%manifest %{name}.manifest
+%license LICENSE
 %{_bindir}/bluetooth-pb-agent
 %{_datadir}/dbus-1/system-services/org.bluez.pb_agent.service
-%{_datadir}/dbus-1/services/org.bluez.map_agent.service
-%{_datadir}/dbus-1/system-services/org.bluez.ag_agent.service
-%attr(0666,-,-) /var/lib/bluetooth/voice-recognition-blacklist
-%{_sysconfdir}/dbus-1/system.d/bluetooth-ag-agent.conf
-%{_libdir}/systemd/user/bluetooth-map-agent.service
-%{_libdir}/systemd/system/bluetooth-pbap-agent.service
-%endif
+%{_unitdir}/bluetooth-pbap-agent.service
+%{_sysconfdir}/dbus-1/system.d/bluetooth_pb_agent.conf
+
+%files hid
+%manifest %{name}.manifest
+%license LICENSE
+%{_bindir}/bluetooth-hid-agent
+%{_datadir}/dbus-1/system-services/org.bluez.hid_agent.service
+%{_unitdir}/bluetooth-hid-agent.service
+%{_sysconfdir}/dbus-1/system.d/bluetooth-hid-agent.conf
 
 %files ipsp
 %manifest %{name}.manifest
 %license LICENSE
-%defattr(-, root, root)
-%{_datadir}/dbus-1/system-services/org.projectx.bt_ipsp.service
-%{_bindir}/bt-ipsp
-%{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-ipsp.conf
+%{_bindir}/bluetooth-ipsp-agent
+%{_datadir}/dbus-1/system-services/org.bluez.ipsp_agent.service
+%{_sysconfdir}/dbus-1/system.d/bluetooth-ipsp-agent.conf
+
+%files tool
+%{_bindir}/hf-test