Modify the agent list for IVI profile
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
index 1624e79..1514011 100644 (file)
@@ -2,7 +2,7 @@
 
 Name:       bluetooth-agent
 Summary:    Bluetooth agent packages that support various external profiles
-Version:    0.1.0
+Version:    0.1.1
 Release:    1
 Group:      Network & Connectivity/Bluetooth
 License:    Apache-2.0
@@ -11,7 +11,7 @@ Source1001:   bluetooth-agent.manifest
 
 BuildRequires:  pkgconfig(aul)
 BuildRequires:  pkgconfig(bluetooth-api)
-%if "%{?profile}" == "wearable"
+%if "%{?profile}" == "wearable" || "%{?profile}" == "ivi"
 BuildRequires:  pkgconfig(alarm-service)
 BuildRequires:  pkgconfig(capi-appfw-app-manager)
 BuildRequires:  pkgconfig(capi-system-device)
@@ -69,6 +69,10 @@ export CFLAGS="$CFLAGS -DTIZEN_SUPPORT_LUNAR_DEVICE"
 export CFLAGS="$CFLAGS -DTIZEN_KIRAN"
 %endif
 
+%if "%{?profile}" == "ivi"
+export CFLAGS="$CFLAGS -DTIZEN_PROFILE_IVI"
+%endif
+
 export CFLAGS+=" -fpie -DPBAP_SIM_ENABLE -fvisibility=hidden "
 export CXXFLAGS+=" -fpie -DPBAP_SIM_ENABLE -fvisibility=hidden "
 
@@ -80,6 +84,9 @@ cmake . -DCMAKE_INSTALL_PREFIX=/usr \
 %else
         -DTIZEN_WEARABLE=0 \
 %endif
+%if "%{?profile}" == "ivi"
+        -DTIZEN_PROFILE_IVI=1 \
+%endif
         -DTIZEN_BT_HFP_AG_ENABLE=1
 
 make VERBOSE=1
@@ -107,7 +114,7 @@ ln -sf %{_libdir}/systemd/user/bluetooth-map-agent.service %{_sysconfdir}/system
 %files
 %manifest %{name}.manifest
 %defattr(-, root, root)
-%if "%{?profile}" == "wearable"
+%if "%{?profile}" == "wearable" || "%{?profile}" == "ivi"
 %{_bindir}/bluetooth-hf-agent
 %{_datadir}/dbus-1/system-services/org.bluez.hf_agent.service
 %exclude %{_libdir}/systemd/user/bluetooth-map-agent.service