Using %license macro to install license file instead of using manual command.
[platform/upstream/atk.git] / packaging / atk.spec
index 097876c..14ec17b 100644 (file)
@@ -1,6 +1,6 @@
-%define baseline 2.12
+%define baseline 2.16
 Name:           atk
-Version:        2.12.0
+Version:        2.16.0
 Release:        0
 License:        LGPL-2.0+
 Summary:        An Accessibility ToolKit
@@ -58,6 +58,7 @@ to develop applications that require these.
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
 %autogen \
@@ -68,20 +69,19 @@ make %{?_smp_mflags}
 %make_install
 %fdupes %{buildroot}
 
-mkdir -p %{buildroot}/usr/share/license
-cp -f COPYING %{buildroot}/usr/share/license/%{name}
-
 %post -n libatk -p /sbin/ldconfig
 
 %postun -n libatk -p /sbin/ldconfig
 
 %files -n libatk
+%manifest %{name}.manifest
 %defattr(-, root, root)
 %doc COPYING
-/usr/share/license/%{name}
+%license COPYING
 %{_libdir}/lib*.so.*
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-, root, root)
 %{_includedir}/atk-1.0
 %{_libdir}/lib*.so