Using %license macro to install license file instead of using manual command.
[platform/upstream/atk.git] / packaging / atk.spec
index 916c597..14ec17b 100644 (file)
@@ -1,43 +1,37 @@
-%bcond_with introspection
-%define baseline 2.12
-%define api_level 1.0
-%define api_level_alpha 10
-
-
+%define baseline 2.16
 Name:           atk
-Version:        2.12.0
+Version:        2.16.0
 Release:        0
-License:        LGPL-2.1+
+License:        LGPL-2.0+
 Summary:        An Accessibility ToolKit
 Url:            http://www.gtk.org/
-#X-Vc-Url:      git://git.gnome.org/atk
 Group:          System/Libraries
 Source:         http://download.gnome.org/sources/%{name}/%{baseline}/%{name}-%{version}.tar.xz
 Source98:       baselibs.conf
 Source1001:     %{name}.manifest
-BuildRequires:  gettext-tools
-BuildRequires:  gnome-common
-BuildRequires:  gtk-doc
+
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  glib2-devel >= 2.35.2
+BuildRequires:  intltool
+BuildRequires:  which
 %if %{with introspection}
 BuildRequires:  gobject-introspection-devel
 %endif
-Requires:       lib%{name}
+Requires:       libatk
 
 %description
 The ATK library provides a set of accessibility interfaces. By
 supporting the ATK interfaces, an application or toolkit can be used
 with screen readers, magnifiers, and alternate input devices.
 
-%package -n lib%{name}
+%package -n libatk
 Summary:        An Accessibility ToolKit
 Group:          System/Libraries
 Provides:       %{name} = %{version}
 Obsoletes:      %{name} < %{version}
 
-%description -n lib%{name}
+%description -n libatk
 The ATK library provides a set of accessibility interfaces. By
 supporting the ATK interfaces, an application or toolkit can be used
 with screen readers, magnifiers, and alternate input devices.
@@ -55,64 +49,41 @@ This package provides the GObject Introspection bindings for ATK.
 
 %package devel
 Summary:        Include Files and Libraries mandatory for Development
-Group:          System/Libraries
-Requires:       lib%{name} = %{version}-%{release}
-%if %{with introspection}
-Requires:       typelib-Atk = %{version}-%{release}
-%endif
+Group:          Development/Libraries/GNOME
+Requires:       libatk = %{version}
 
 %description devel
 This package contains all necessary include files and libraries needed
 to develop applications that require these.
 
-
 %prep
 %setup -q
 cp %{SOURCE1001} .
 
 %build
-NOCONFIGURE=1 ./autogen.sh
-
-%configure \
+%autogen \
   --disable-static
-
-%__make %{?_smp_mflags}
-
+make %{?_smp_mflags}
 
 %install
 %make_install
-install -d %{buildroot}/usr/share/help
+%fdupes %{buildroot}
 
-%find_lang %{name}%{api_level_alpha}
-fdupes %{buildroot}
+%post -n libatk -p /sbin/ldconfig
 
-%post -n lib%{name} -p /sbin/ldconfig
+%postun -n libatk -p /sbin/ldconfig
 
-%postun -n lib%{name} -p /sbin/ldconfig
-
-%files -n lib%{name}
+%files -n libatk
 %manifest %{name}.manifest
 %defattr(-, root, root)
+%doc COPYING
 %license COPYING
 %{_libdir}/lib*.so.*
 
-
-%if %{with introspection}
-%files -n typelib-Atk
-%manifest %{name}.manifest
-%defattr(-, root, root)
-%{_libdir}/girepository-%{api_level}/Atk-%{api_level}.typelib
-%endif
-
 %files devel
 %manifest %{name}.manifest
 %defattr(-, root, root)
-%{_includedir}/%{name}-%{api_level}
+%{_includedir}/atk-1.0
 %{_libdir}/lib*.so
 %{_libdir}/pkgconfig/*.pc
-%if %{with introspection}
-%{_datadir}/gir-%{api_level}/*.gir
-%endif
-
 
-%lang_package -f %{name}%{api_level_alpha}